Please nominate your Qt Champions for 2021!

Solved (actually worked around): QT Creator not seeing header files on WinXP

  • Hello,

    I had an appliction building just fine on QT Creator on my desktop computer running Win 7. So, now I installed QT SDK on this notebook running WinXP and copied my project to that computer. I changed all the path statements in my project file to correspond to the new environment. So, I go to build the app and it says that it cant see a key header file. I look on source code file and sure enough it is underlined and the hover message confirms that it doesn't see the header. Well, I checked the path to the file in the project folder and it is correct. Here's the include statement.

    INCLUDEPATH += C:/RBackhus/DDNDUALV6_PCIE4/Host_Software/emu/App/out_release/1.3.5/Software/emu/App/source/EMULIB

    There are other include statements to other headers from other vendors and QT is seeing them just fine.

    Does anyone see anything wrong with this include statement? Does anyone have any idea what might be going on?

    Thank you.


  • Delete all Makefiles in your project directory and try build again.

  • try it :
    INCLUDEPATH +=$$quote(C:/RBackhus/DDNDUALV6_PCIE4/Host_Software/emu/App/out_release/1.3.5/Software/emu/App/source/EMULIB)@

  • Thank you for your answers. I'll try these when I get time. In the interest of expediency, I copied all the header and other vendor provided files into a subfolder to the project folder and changed all the paths in the project file to reflect this. Of course I also had to go into the vendor's source files and change their embedded #include statements since they all were hardwired to the vendor's directory structure. This of course drives me up a tree. Why bother to specify include files in both the project folder and source files? Distributing a hard wired directory structure throught out source code is just idiotic!!! I complained to the vendor about this because they did the same thing in their HDL code but the clown who owned the company just got angry.

    Well, anyway, the problem was worked around but I'll call it solved.

Log in to reply