Qt Application .exe fails to open properly



  • I am new to Qt, and I am having issues getting a .exe to open properly. Simply put, program opens but only displays a white window with the proper window name.
    I'll first explain everything I did and attempt to be thorough.

    1 Installed Qt from the offline installer: QtSdk-offline-win-x86-v1_2_1.exe (I have an x64 machine, didn't see a downloader for it)

    • Went through tutorial: Creating a Qt Quick Application (Transitions)
    • End program ran fine in Qt using Run command

    2 Attempted to Open .exe in Debug Folder

    • Warning about DLLs required
    • Copied required DLLs one at a time as asked upon each successive open (looped through this step a bit)

    3 Attempted to Open .exe in Debug Folder Again (post DLL-copying)

    • Window labelled Transition opens
    • Only consists of while box, nothing like what shows up during run command

    4 Used Dependency Walker to verify DLLs

    • Said that IEShims.dll was also required, so I copied that into the folder as well

    5 Still stuck with the white window

    Any help would be greatly appreciated!

    Thanks,
    Brett Sparkman

    Edit: Made it more readable. Spaces with newlines didn't work right, and I failed to preview before. The order I ran things in is top-down. Please forgive the poor numbering as well; I don't post on forums very often.



  • Im having a very similar problem but havent been able to figure out how to work it out, so I hope someone can help you out so we can both figure this out.

    sorry I cant be of any help



  • Hello,
    What are debug console output messages (if any)? It may be you have an error in your QML files.



  • mine wouldnt work when I tried the other day but I have not completely finished my program so I decided not to worry about it yet and I had removed the .dll files from my folder. After I saw this and commented it on I decided to try again and I got the same errors as before about the .dll and one by one, just like you said, I copied in the required .dll files, to the debug folder. Once I had all that it needed I tried opening it again and it worked. I didn't do anything differnt that I know of unless some change I made to the program recently somehow effected it.

    I know this doesn't really help you much but I figured I would share.



  • Thanks for the posts. I tried re-copying the .dlls again, and it still didn't work. I also tried using release mode (had to change from the *d*.dlls to the *.dlls), and that didn't solve the issue either.

    As far as outputs messages go:

    • Application Output: Starting C:*\Qt\Transistion-build-desktop-Qt_4_8_1_for_Desktop_-_MinGW__Qt_SDK__Debug\debug\Transistion.exe...
      Qml debugging is enabled. Only use this in a safe environment!
    • Compile Output: 13:53:57: Running build steps for project Transistion...
      13:53:57: Configuration unchanged, skipping qmake step.
      13:53:57: Starting: "C:\QtSDK\mingw\bin\mingw32-make.exe"
      C:/QtSDK/mingw/bin/mingw32-make.exe -f Makefile.Debug
      mingw32-make.exe[1]: Entering directory C:/*/Qt/Transistion-build-desktop-Qt_4_8_1_for_Desktop_-_MinGW__Qt_SDK__Debug' Copying application data... 2 File(s) copied mingw32-make.exe[1]: Leaving directoryC:/*/Qt/Transistion-build-desktop-Qt_4_8_1_for_Desktop_-_MinGW__Qt_SDK__Debug'
      Copying application data...
      2 File(s) copied
      13:53:58: The process "C:\QtSDK\mingw\bin\mingw32-make.exe" exited normally.

    These seemed normal to me, but I don't have very much experience.

    Thanks,
    Brett


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.