[solved] Can't start process install_name_tool (Mac OSX Snow Leopard 10.6.8)



  • Hi there,

    if I try to install the Qt SDK version 1.2.1 on my Mac (Snow Leopard), I'm getting an error message:
    "
    Error during installation process
    (cpm.nokia.ndk.api.qtcomponents.simulator.gcc):
    Can't start process install_name_tool.
    "

    Yes, I've found that topic in the forum and the bottom line of all entries was that the installer needs to know about the C compiler. But all topics (and the solutions I've found) were for OSX Lion and Xcode comes without the command line tools on those machines.

    I would say the installer complains about the install_name_tool that is in the same path like the gcc.
    If I open a terminal window, I can "get" the path:

    @
    lastenhuone:~ sven$ which install_name_tool
    /Developer/usr/bin/install_name_tool
    lastenhuone:~ sven$ which gcc
    /Developer/usr/bin/gcc
    lastenhuone:~ sven$
    @

    What are my missing bits and pieces?



  • Have you tried to install the latest version of Xcode and Developer Tools for your Mac?



  • Yes, I've installed the latest version of Xcode on my Mac (4.2 build # 4C199 for Snow Leopard that is).



  • BTW: on OSX Lion it works like charm. But I've got one Mac that will not be upgraded, so any help for OSX Snow Leopard is still appreciated.





  • Ok, I found a solution and to safe your time I will only mention the solution that worked for me and not all the failures during try and error.

    Prerequisites: Mac OSX 10.6.8 (Snow Leopard), Code 4.2 (build # 4C199) installed. QtSdk-offline-mac-x86-v1.2.1.dmg downloaded.

    The reason that the setup does not work is the PATH environment variable. Even if you can see a valid PATH in a terminal window, that doesn't necessarily help, because it is a difference if an application is launched via terminal or via Finder.

    Open a terminal window (, make sure that you are in your home directory) and enter the following commands:

    @mkdir .MacOSX
    cd .MacOSX/
    touch environment.plist@

    This creates an empty property list in the hidden directory .MacOSX .

    Finder does not show you hidden files and directories, so enter

    @defaults write com.apple.finder AppleShowAllFiles TRUE
    killall Finder
    @

    Now the empty property list should show up and you can edit it with a right click and "open with property list editor". Since you've installed Xcode, you should have it somewhere.

    Create a new entry under the root node of type "string" and give it the name PATH. Value should be what you have as path in your terminal window plus the path to the make command. In my case it's
    @/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/Developer/usr/bin:/usr/X11/bin@

    To hide all the invisible files again enter
    @defaults write com.apple.finder AppleShowAllFiles FALSE
    killall Finder
    @

    in your terminal window.

    Log off.
    Log on.

    Now the new settings should work and you can start the APP that is contained in your QtSdk-offline-mac-x86-v1.2.1.dmg file.

    Extra hint: the QtCreator App is not in the /Applications folder, it goes in that directory where you've installed the SDK.

    Now that the SDK is installed I've got some other problems but this one is solved :-)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.