Unable to install on Mac OSX Lion 10.7.4 with QtSdk-online-mac-x86-v1.2.1 on MacBook Air



  • Ok, I'm new to QT. I tried going to qt.nokia.com website and selecting Macintosh and downloading the online installer. I tried running it but it said I needed Xcode. Not sure if it was reporting I didn't have it or warning me I needed it. This was ambiguous. Since I didn't have it though, I went to the App Store and downloaded and installed Xcode. Then tried to install again. It warned me again, but I continued past the warning. Eventually it failed with an "Error during installation process (com.nokia.ndkapi.qtcomponents.simulator.gcc) Can't start process install_name_tool).

    I thought maybe XCode needs further installation and when I clicked on it indeed it wanted more install. I did that and was able to get Xcode to come up. I then closed and tried the install again. Same problem

    Not sure what is happening. Is there something further to install, is that what the warning indicates? Or is there something else missing? Or is this just not compatible with Lion?

    Thanks.



  • This also happens to me after I upgraded to Mac OS X 10.7.4 ... Any solutions anyone?
    Thanks



  • Ok, I updated my xCode o latest version 4.4.1, still the same problem :(((
    Then I thought, Ok, I'll move to Windows to develop on my N9; Since the last time I used Qt SDK with N9 on Windows, I upgraded my N9 to latest PR 1.3 and I think also I updated the Qt SDK; Now I can not deploy the developer keys (or whatever they are called, you know the 1st thing you have to do to configure Qt Creator to be able to deploy on the N9). Qt Creator gives this error when trying to deploy the keys: "Connection failed: Timeout waiting for reply from server"

    So I can not develop for the N9 neither on Mac, nor on Windows ... The worst thing is that I don't think is anyone left at Nokia to support with these issues, just great.



  • Ok, I found the solution for Windows: the problem was the usb dribver for N9 was not found; just install it manually from C:\QtSDK\Madde\usbdriver



  • I think you must load the command line tools from inside Xcode (should be in the preferences pane).



  • You should use Ubuntu it is much easier and much more reliable for anything related to Open Source not to mention the fast growing number of apps and their amazing quality. Apple is on a path to lock down all their plateforms that includes OS X and iOS... Quite surprising given how that same strategy has hurt the company in mid 90s... Those issues on OS X are going to be more more common with more and more software. Apple intentionally remove simple yet useful tools like wget or like the GNU TLS, why? Who knows? They by default do not allow App not in the AppStore on latest OS X you have to search in the deep end of the Preferences to find the obscure checkbox that will let you download apps outside of the AppStore, absolutely ridiculous. They also no longer install by default the command line tools that allow you to do some development outside of the scope of the OS X/iOS App, another ridiculous and antisocial decision. I wonder if all that would have happened under Steve Jobs and his wisdom from the dark days of Apple in the 90s when he had engaged in a similar strategy that almost drove the company into bankruptcy at the time.



  • @carbon_dragon does it work for you now?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.