Can't run demo project "Paths Stroke"



  • Hello !

    I'm new to QT and wanted to play around with it.
    Found an interesting demo project named "Paths Stroke", but running it produces the following error:

    c:/qtsdk/mingw/bin/../lib/gcc/mingw32/4.4.0/../../../../mingw32/bin/ld.exe: cannot find -ldemo_shared
    collect2: ld returned 1 exit status
    mingw32-make.exe[1]: *** [debug\pathstroke.exe] Error 1
    mingw32-make.exe: *** [debug] Error 2
    17:15:32: The process "C:\QtSDK\mingw\bin\mingw32-make.exe" exited with code 2.
    Error while building project pathstroke (target: Desktop)
    When executing build step 'Make'

    I have Visual Studio 2010 installed, but even though I changed the compiler from MSVC to MINGW, I still get the same error.
    Some other demos do work, but some don't with this message.

    Has anyone else encountered with this irritant ?



  • Hi there,
    When changing the compiler settings you need to run the QMake and after that run a clean build. Might solve the issue.
    I will try to build the example in the latest Qt designer.
    Got the same problem here!! It might be a bug in the demo, you can report this.
    greetz


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.