0xc000007b error



  • Hello,
    I am trying to release my Qt application.
    I compiled it using the "Release" configuration of Visual Studio 2010. It works fine on my own computer but not on others (or virtual machines).
    First, when I tried to execute the application, it said that three needed libraries weren't found: "QtCore4.dll", "QtGui4.dll" and "msvcp100.dll".
    So I copied those files from \Qt\4.8.2\bin and C:\Windows\System32 into the same folder as the application.
    Now, I get another error message when I try to execute it. It says, that the application encountered the error written in the title while running.
    Help me, please.



  • Have a look at "this thread":http://social.msdn.microsoft.com/Forums/en/vsdebug/thread/f99d3cb8-963e-4a35-afe2-d7b9037a11c4 and the thread linked in that thread.



  • Thanks for the answer.
    I don't quite understand on what part of the thread you are refering to. Could you be more specific?

    The first topic is similar but still different. The person can't even run his application on his own computer. That is not the case for me, so I think changing the Visual Studio options is unlikely to help.

    The second topic gives two advices:

    1. Link statically - I am trying to do so but encountered several compiler problems. Thus, I can't tell this will be a solution.
    2. Check the required libraries - Dependency Walker shows the three libraries I listed up in my starting post as well as kernel32.dll which is on every Windows machine.


  • I think your problem is related to missing or incorrect dlls. But there is just not enough information provided to pinpoint the problem. You could either try to remote debug your application or you create a dumpfile and analyze that. I hope this way you can find out what your problem is.

    Another wild guess is that maybe the two PCs (your development Pc and the deployment PC) differ in there setup (for example different service pack versions, or visual studio runtime updates).

    But at first I would advise you to use the dependencywalker and then either remote debug or create a dumpfile.



  • I tried to install rdbgsetup_x64.exe so I can debug the application. I start the remote debugger, then I start my own application which crashes, but the debugger shows nothing.

    Same result for creating a dump file. It doesn't give any information about the error.

    Other programs, which don't use Qt, work on both my and the other computer. So it can't be because of different setups.



  • Did you follow all "these steps":http://msdn.microsoft.com/de-de/library/bt727f1t.aspx for remote debugging ?



  • I found the problem. Apparently, the Visual C++ Redistributable installation was corrupt and therefore the required DLL was damaged.

    Anyway, thanks for trying to help me :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.