[Solved] Error building qt-everywhere-opensource-src-4.8.2



  • Hello,

    After extracting the tar file I did the following steps:

    1. ./configure
    2. gmake

    After a while I got the following errors:

    bq.

    gmake[2]: Entering directory /opt/qt-everywhere-opensource-src-4.8.2/src/3rdparty/webkit/Source/JavaScriptCore' g++ -c -pipe -Wall -Wextra -Wreturn-type -fno-strict-aliasing -Wcast-align -Wchar-subscripts -Wformat-security -Wreturn-type -Wno-unused-parameter -Wno-sign-compare -Wno-switch -Wno-switch-enum -Wundef -Wmissing-noreturn -Winit-self -Werror -fno-stack-protector -O3 -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -D_REENTRANT -DNDEBUG -DBUILDING_QT__=1 -DNDEBUG -DQT_ASCII_CAST_WARNINGS -DBUILDING_JavaScriptCore -DBUILDING_WTF -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_HAVE_SSE3 -DQT_HAVE_SSSE3 -DQT_SHARED -I../../../../../mkspecs/linux-g++ -I. -I../../../../../include/QtCore -I../../../../../include -I. -I../../Source -I../ThirdParty -Iassembler -Ibytecode -Ibytecompiler -Iheap -Idfg -Idebugger -Iinterpreter -Ijit -Iparser -Iprofiler -Iruntime -Iwtf -Iwtf/gobject -I/opt/qt-everywhere-opensource-src-4.8.2/src/3rdparty/webkit/Source/JavaScriptCore/wtf/symbian -Iwtf/unicode -Iyarr -IAPI -IForwardingHeaders -Igenerated -I../../Source -I../../include -I/include/QtWebKit -I/include -I.moc/release-static -o .obj/release-static/YarrInterpreter.o yarr/YarrInterpreter.cpp cc1plus: warnings being treated as errors ./wtf/PassOwnPtr.h: In instantiation of ‘WTF::PassOwnPtr<JSC::Yarr::ByteDisjunction>’: yarr/YarrInterpreter.h:328: instantiated from here ./wtf/PassOwnPtr.h:81: warning: lowering visibility of ‘WTF::PassOwnPtr<U> WTF::adoptPtr(U*) [with U = U, T = JSC::Yarr::ByteDisjunction]’ to match its type ./wtf/PassOwnPtr.h: In instantiation of ‘WTF::PassOwnPtr<JSC::Yarr::BytecodePattern>’: yarr/YarrInterpreter.cpp:1451: instantiated from here ./wtf/PassOwnPtr.h:81: warning: lowering visibility of ‘WTF::PassOwnPtr<U> WTF::adoptPtr(U*) [with U = U, T = JSC::Yarr::BytecodePattern]’ to match its type gmake[2]: *** [.obj/release-static/YarrInterpreter.o] Error 1 gmake[2]: Leaving directory/opt/qt-everywhere-opensource-src-4.8.2/src/3rdparty/webkit/Source/JavaScriptCore'
    gmake[1]: *** [sub-JavaScriptCore-JavaScriptCore-pro-make_default-ordered] Error 2
    gmake[1]: Leaving directory `/opt/qt-everywhere-opensource-src-4.8.2/src/3rdparty/webkit/Source'
    gmake: *** [sub-webkit-make_default-ordered] Error 2
    [root@localhost qt-everywhere-opensource-src-4.8.2]#
    bq.

    What is the reason for the error ?
    Following are the details of the gcc , distribution.
    bq
    more /proc/version
    Linux version 2.6.18-274.12.1.el5 (mockbuild@builder10.centos.org) (gcc version
    4.1.2 20080704 (Red Hat 4.1.2-51)) #1 SMP Tue Nov 29 13:37:35 EST 2011
    bq.

    Can you help ?
    Thanks,
    Zvika



  • Is it possible to upgrade to a more recent gcc version, as it is most probably the source of this error?

    If not, try to remove the <code>-Werror</code> compilation flag, see also "this":http://qt-project.org/forums/viewthread/13514 thread.



  • Dear Mr. Geyer,

    ./configure -no-webkit solved the problem.

    Your help is highly appreciated.
    Zvika.



  • 1 - find this file : <qt 4.8.2>/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h
    2 - replace this line : typedef struct _GMutex GMutex;
    with this line : typedef union _GMutex GMutex;


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.