Important: Please read the Qt Code of Conduct -

The speed of applications

  • Hi,

    I have been using mini2440 and micro2440 too and I am absolutely satisfied with them. I use Qt too. I have got only one problem. But this makes me crazy. :-) My applications are slow. I absolutely cannot figure out what the problem is.

    When I wrote “slow” I meant it is 2-4 seconds between any two GUI operations. So it is a really big problem to me. I haven’t found anybody with the same problem even though I had visited many forums. I tried with compiled Qt as well to avoid my errors but the result was the same. I also was thinking of switching optimization but it was said that it wouldn’t work.
    Any help or advice would be great. :-)

    I made a video to illustrate my problem. You can reach it on the following link:

    The languages is not important. But you can see the long delay.

    Best luck for us, :-)

  • if you have a profiler for your setup, and see which parts of the application take most time. You can try valgrid/calgrind. Mostly its a matter of compiling and running those application.

  • Thanks, I will check it. D.

  • There is one more thing. I compiled it for host too. It worked perfectly. My host is a ubuntu under VMplayer. So the host is not fast.

  • Not sure if this will help, but when we were developing on a system with similar specs we found that style sheets and complex layouts were the slowest points in our application.

  • Hi,
    I am again. I have checked what you had recommended.
    As I mentioned there is no problem in the environment of my host.
    Is it true, that I cannot use this on my mini2440? (I am not sure, because this is the first time I try to use valgrind).

    I have just seen your answer. I agree with you, that there are some widgets which are a bit slower than others. But I suppose some should work better. I would improve them. Thank you really. :-)


  • I have read that different Qt has different speed. Therefore I would like to compile the newest, maybe It is enough fast.
    I downloaded it. I started to compile it, but I found some differences.

    1. The g++.conf file has been devide into two different file. Both of two files contain flags for optimization. Where I can switch of the optimization?
    2. I cannot configure. The old one that I used until yet is the next:
    3. /configure -embedded arm -xplatform qws/linux-arm-g++ -prefix /usr/local/Qt -qt-mouse-tslib -little-endian -no-webkit -no-qt3support -no-cups -no-largefile -optimized-qmake -no-openssl -nomake tools -qt-sql-sqlite -no-3dnow -system-zlib -qt-gif -qt-libtiff -qt-libpng -qt-libmng -qt-libjpeg -no-opengl -gtkstyle -no-openvg -no-xshape -no-xsync -no-xrandr -qt-freetype -qt-gfx-linuxfb -qt-kbd-tty -qt-kbd-linuxinput -qt-mouse-tslib -qt-mouse-linuxinput

    But it doesn’t work. I got the next message:
    qt-gif: invalid command-line switch
    -qt-gfx-linuxfb: unknown argument
    -qt-kbd-tty: unknown argument
    -qt-kbd-linuxinput: unknown argument
    -qt-mouse-tslib: unknown argument
    -qt-mouse-linuxinput: unknown argument
    You have not explicitly asked to use pkg-config and are cross-compiling.
    pkg-config will not be used to automatically query cflag/lib parameters for

    If it is possible I would like to compile with static flag to reach better speed. How can I do it?
    Thank you, D.

  • Hi,

    i know its a long time since your post but I bought a mini2440 a few weeks ago and now have the same problems...
    Did you (successfully) solved your problem?

    Thanks and best regards

  • I don't know if it is the same problem... but I found on the Qt 5.1 and Qt 5.2 beta1 on Android and iOS that the QML Text item make a very long time to load. But after that, it's very fast.
    So, I had the same problem of switching from a screen to another (I'm talking about QML), and to solve it, I loaded all the QML Text items at the startup and then all switching between screens are now very fast.
    But, now the startup of the application takes almost 10 seconds :-(

  • Hi,

    thanks for your reply, but this problem occurs with qt4.6.2; so no qml...

    Best regards

Log in to reply