Qt5 Embedded Linux



  • Hi - another newbie!!!

    I've just about managed to get Qt setup for the Raspberry Pi. I can compile, deploy and run the hello-qtonpi example app on the RPi so happy days. I've tried several other Qt5 examples as well - most execute properly. I am unable to get a mouse to work on any of them though. Taking a guess, the lack of a mouse is to do with where the Qt SDK is listening for it, from what I've read so far mouse events should propogate through the SDK if the SDK is configured properly.

    So I have a question if anyone can help. How do I configure the qtonpi Qt5 SDK with a mouse, when I plug a mouse in the RPi does seem to detect it - but I have no idea how to tell Qt how to talk to it.

    I'm new to both linux and Qt so this may well be a stupid question!!

    I'm using:
    Ubunto 12.04 64 bit, Qt Creator 2.4.1 (I Couldnt get Qt Creator 2.5.0 to deploy to the Pi), Qt5.0 SDK and the standard qtonpi SD card image.

    Any guidance or pointers on what to read next would be much appreciated.



  • I have implemented the EvDevMouse plugin.
    I was able to get the mouse working. But i was not able to see the mouse pointer.
    Movement / Click was taken by the app. I checked with Examples (Animation->Appchooser) and QtTestBrowser. Both have same issue.



  • Hi hari

    Looks like its to do with the QPA mouse driver plugin then.

    Do you think this is right:

    1. QPA server must be running - I think this must be or no graphics! (possibly not though because of the GPU hardware accelaration under Qt5.

    2. QPA linux mouse plugin must be loaded.

    Assume its the same for the keyboard driver too!

    I've tried starting the app with -plugin foo (linux mouse driver - forget the exact syntax) with no success.



  • Mouse problem will be fixed in next release.

    https://codereview.qt-project.org/#change,23118



  • With exporting QT_DEBUG_PLUGIN=1, you can see if the plugin is found.
    if the "Key" word matches with what every you have passed for -plugin, then it should be initialized. If further to that if its not working, then probably you are not getting mouse events.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.