Application not running on device



  • Hey

    I have developed a Qt application using QtSDK4.6.3 and Qt Mobility1.0.2 my application gets the latitude and longitude through the device and writes it to a .txt file which is simultaneously created in the phone memory(C:). The application installs on the phone normally but it doesn't open on the application. after removing the Qt Mobility components for GPS and the file handling code, the application runs normally. Qt mobility for the device is installed in it. What is the problem?


  • Moderators

    Did you check the capabilities required? I am pretty sure you will need something special to access location data on symbian.



  • In my application in the .pro file i have given the following code:

    CONFIG += MOBILITY
    mobility += location

    symbian:TARGET.CAPABILITY += NetworkServices Location

    what else do i need to add??


  • Moderators

    No idea, I never wrote any major program for symbian, sorry!

    Try adding all the capabilities you can get and check whether the app works then. Then remove capabilities till the app stops working again. Read/WriteUserData seem to be necessary for a surprisingly big list of things... Creating files also tends to be tricky, depending on where you want to store them.



  • i edited the code to just get the position of device. no writing. i added all the capabilities, still when i install on the device it won't run. I noticed one thing, there is no option to create the smart installer package in the Qt Project setup options. But without the positioning code (where the app is just a layout), it runs perfectly. i also tried running the application on symbian belle by deploying it through qt 4.7.4 and mobility 1.2.0 . Still it doesnot open. What seems to be the problem?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.