I cannot see anything con console - ubuntu pangolin [12.04]



  • Hi all.
    I am studying C++ and I have chosen QtCreator to make my practices ... The problem is that I am going to do console applications until I learn more about create and manage classes in C++.

    I installed QtCreator 2.4.1 on my linux ubuntu 12.04 LTS and have chosen the option that appears in menu "File-> New Project or File-> Other proyects-> Plain C++ Project" and this creates an application "HelloWorld".

    But when the application starts the console does not display anything. Is there something I must configure?



  • When you say "the console" where do you mean? That template creates a project for program that outputs text. That project should have been configured to open a separate terminal. Do you see a separate terminal? If so, the output should be there:
    @
    Hello World!
    Press <RETURN> to close this window... @

    If you got no terminal at all then check:

    • Project (Ctrl-5), Run Settings, Run in terminal is checked
    • Tools menu, Options..., Environment page, General tab, Terminal command. Defaults to "xterm -e". Is xterm installed? You can use other terminals but I have yet to make KDE konsole work. I cannot vouch for Gnome-ish terminals.


  • It works! Thanks

    • I saw the terminal but the terminal did not show anything.

    • (run in terminal is checked)

    • But in Environment->General the terminal was set up at "x-terminal-emulator -e". I replace it for xterm -e and It works fine. Thanks!



  • The C++ code is not the issue here.

    What is the terminal program? What are the settings under Tools Options? What, if anything, is showing in the "Application Output" pane inside the Qt Creator?

    Edit: I see you fixed it an edited your post while I was writing :)



  • Yes, thanks, I was trying with "xterm -e" instead of "x-terminal-emulator -e" just after I have written "(run in terminal is checked)" xD


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.