Important: Please read the Qt Code of Conduct -

Is there a specific version of QtCreator that is compatible with a 2.6.3 Linux kernel?

  • I've downloaded the SDK and when I try to execute the .run file (, I'm seeing the following errors,
    which suggest to me that the Linux libraries are out of date for the Qt SDK I'm trying to use.

    I'm hoping someone knows what SDK version might be compatible with older Linux kernels.


    [root@sfstest4 opt]# ./
    ./ /usr/lib/ version GLIBCXX_3.4.9' not found (required by ./ ./ /usr/lib/ versionGLIBCXX_3.4.11' not found (required by ./
    ./ /lib/tls/ version GLIBC_2.9' not found (required by ./ ./ /lib/tls/ versionGLIBC_2.10' not found (required by ./
    ./ /lib/tls/ version GLIBC_2.11' not found (required by ./ ./ /lib/tls/ versionGLIBC_2.4' not found (required by ./
    ./ /lib/tls/ version `GLIBC_2.7' not found (required by ./
    [root@sfstest4 opt]#

  • Moderators

    The kernel should not matter too much... the glibc as well as the libstdc++ do though!

    To get Qt and Creator running on such a system you will most likely need to build them yourself, provided your distribution does not ship them for you.

Log in to reply