Qt library 4.8.1, QWSLock::up(): Invalid argument



  • Dear All,
    I built Qt library 4.8.1 for embedded. And after deploying Qt onto the development board. I got outputs from an Qt application run:

    QWSLock::up(): Invalid argument
    QWSLock::up(): Invalid argument
    QWSLock::down(): Invalid argument
    QWSLock::up(): Invalid argument
    QWSLock::up(): Invalid argument
    QWSLock::down(): Invalid argument
    QWSLock::up(): Invalid argument
    QWSLock::up(): Invalid argument
    QWSLock::down(): Invalid argument

    I found this message is generated in "src/gui/embedded/qwslock.cpp". And it is output by qDebug(). I don't know if this message will cause some bad things to the application running. Currrently, the application runs fine.

    My configure command with parameters:
    ./configure -v -release -opensource -qconfig dist -shared -fast -no-largefile -no-exceptions -no-accessibility -no-qt3support -no-declarative -no-xmlpatterns -no-phonon -no-phonon-backend -no-scripttools -no-svg -xplatform qws/linux-arm-g++ -embedded arm -qt-zlib -qt-libtiff -qt-libpng -qt-libmng -qt-libjpeg -no-nis -no-iconv -no-glib --prefix=/path/to/my/prefix/ -webkit -dbus -qt-freetype -openssl -depths all -plugin-gfx-linuxfb -plugin-gfx-transformed -plugin-mouse-tslib -no-pch -nomake tools -L/third-party/lib -I/third-party/include

    Do I need to build "Debug" version of Qt library to detect this issue further.

    Thanks so much.

    Best regards,
    Jiejun Qiu



  • Jiejun,

    Have you seen this link: http://www.mail-archive.com/community@lists.openmoko.org/msg65512.html

    We are having the same problem, and this patch fixed the issue.

    I'm trying to file a bug report with QT to get this issue officially resolved.

    Regards,

    Jeff Lance



  • I had found that patch worked for me too, and was surprised it wasn't in qt 4.8.4 recently released at end of Nov.

    --DaveM




Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.