Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Paths and environment settings - need help



  • I'm a first time Qt user, trying to use qtcreator to develop an app for embedded linux, using a toolchain created by buildroot, using linux as my dev box. I can't seem to find docs/answers to what I'm guessing are PATH/ENV settings.

    Details:
    I'm trying to build the clocks example that comes with the QtSDK, under directory Examples/4.7/declarative/toys/clocks.
    I've selected my toolchain/compiler in the "Build settings" screen, will provide details if needed.
    The only funny thing is a little yellow exclamation in "Qt Versions" screen which I'm assuming is because of the "No qmlviewer installed" (I assume that means no qmlviewer in the buildroot toolchain)

    ERRORS:
    The first error in the "Issues" screen when I try to build is:

    error: /home/XXXXX/Projects/buildroot-2012.02/output/host/usr/i586-unknown-linux-uclibc/sysroot/lib/libpthread.so.0: no version information available (required by /lib/i386-linux-gnu/librt.so.1)
    File not found:

    What I don't understand here is, why is it looking in /lib for librt instead of in /home/XXXXX/Projects/buildroot-2012.02/output/host/usr/i586-unknown-linux-uclibc/sysroot/lib/
    Or am I completely misunderstanding the output?

    NOTE - I've set LD_LIBRRARY_PATH in the "Build Environment" settings to
    /home/XXXXX/Projects/buildroot-2012.02/output/host/usr/i586-unknown-linux-uclibc/sysroot/usr/lib:/home/XXXXX/Projects/buildroot-2012.02/output/host/usr/i586-unknown-linux-uclibc/sysroot/lib in order to "fix" a problem with qmake not finding libm.so.0

    /home/XXXXX/Projects/buildroot-2012.02/output/host/usr/bin/qmake:-1: error: error while loading shared libraries: libm.so.0: cannot open shared object file: No such file or directory

    Maybe this is my "real" problem...???

    Something is wrong - but I can't find any docs explaing what qtcreator is expecting for path and environment variables.


Log in to reply