Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

FAILED compile for arm.v5.udeb.gcce4_4_1 error



  • hi everyone. i am building an application in qt & it is showing this compiled output. can really make out what is the problem:

    sbs: build log in C:\QtSDK\Symbian\SDKs\Symbian3Qt474\epoc32\build\Makefile.2012-04-30-10-56-30.63-4644.log

    FAILED qmake_extra_pre_targetdep for arm.v5.udeb.gcce4_4_1: epoc32\new2\moc\moc_mydialog27.cpp

    FAILED qmake_extra_pre_targetdep for arm.v5.udeb.gcce4_4_1: epoc32\new2\moc\moc_user_data.cpp

    FAILED qmake_extra_pre_targetdep for arm.v5.udeb.gcce4_4_1: epoc32\new2\moc\moc_mydialog27.cpp

    FAILED qmake_extra_pre_targetdep for arm.v5.udeb.gcce4_4_1: epoc32\new2\moc\moc_user_data.cpp

    FAILED compile for arm.v5.udeb.gcce4_4_1: epoc32\build\new2\c_816283a24d5f3714\new2_exe\armv5\udeb\moc_mydialog27.o
    mmp: new2_exe.mmp

    FAILED compile for arm.v5.udeb.gcce4_4_1: epoc32\build\new2\c_816283a24d5f3714\new2_exe\armv5\udeb\moc_user_data.o
    mmp: new2_exe.mmp
    mingw32-make[1]: *** [C:/QtSDK/Symbian/SDKs/Symbian3Qt474/epoc32/build/new2/c_816283a24d5f3714/new2_exe/armv5/udeb/moc_mydialog27.o] Error 1
    mingw32-make[1]: *** Waiting for unfinished jobs....
    mingw32-make[1]: *** [C:/QtSDK/Symbian/SDKs/Symbian3Qt474/epoc32/build/new2/c_816283a24d5f3714/new2_exe/armv5/udeb/moc_user_data.o] Error 1
    sbs: error: The make-engine exited with errors.
    make.exe: Leaving directory `C:/QtSDK/Symbian/SDKs/Symbian3Qt474/epoc32/new2'
    make.exe: *** [debug-gcce] Error 1
    10:56:41: The process "C:\QtSDK\Symbian\SDKs\Symbian3Qt474\epoc32\tools\make.exe" exited with code 2.
    Error while building project new2 (target: Symbian Device)
    When executing build step 'Make'

    can anybody propose some solution ???



  • What are your build steps? Are you making off the command-line or using QtCreator?



  • hi jmoellmer. i am using qt creator 1.2 & building mobile application in it.


  • Moderators

    Qt Creator 1.2 is OLD and symbian and especially sbs support has much improved since those times.

    I suggest getting Qt Creator 2.4.1.



  • thank you tobias hunger. please also provide here the link to download Qt Creator 2.4.1


  • Moderators

    Please follow the "DOWNLOADS" link at the top of this page.

    Are you actually using Qt Creator 1.2 (Check Help->About Qt Creator while running it) or are you using the Qt SDK of version 1.2? Qt SDK 1.2 should have a fairly recent Qt Creator included...



  • hi tobias hunger. i am using qt sdk 1.2. it is based on qt 4.7.4. also, to download qt sdk 2.4, i have followed this link:
    "releases.qt-project.org/qtcreator/source/qt-creator-win-opensource-2.4.1.exe". while installation, it does not highlight the option to install install qt sdk.


Log in to reply