Deployment cancelled due to CODA app connection



  • While Deploying the program on device, a pop up message showed which cancelled my deployment and said, "Qt Creator is waiting for the CODA application to connect. Please make sure that application is running on your mobile phone and the right IP Address and/or port are configured in the project settings." The compile output said that it already produced a .sis file. After that, i installed the app on phone but instead of showing the application, it only showed a black screen.

    Below is the screen shot of the configurations i did on the Run Settings on Qt
    http://www.mediafire.com/i/?3870wziwo25i99q()

    Can anyone help me?



  • You need to have the CODA application running on your symbian phone before you can deploy to it using Qt Creator. You will have to first install it on your phone (you will find it under the Qt SDK) and you have to start it manually.



  • I have already installed CODA application on my symbian phone and when I open CODA on my phone, it says:

    Status: Connected
    Connection: USB
    Port: 0

    What could I possibly be doing wrong?



  • I can't access your image with the settings right now but... If Qt creator shows you the "play" button green is because it recognizes that the phone is connected (assuming that you have selected the right target)...
    Make sure you have the CODA that comes with the SDK (I think I had problems because of not updating it in the past). Restarting the phone after installing it can't hurt either :)



  • I tried restarting the phone and run the application on device, now nothing happens after pressing the icon



  • That is odd....
    I don't remember: when you connect the phone to the usb cable does it ask you in what mode?
    Can you install the application (or any other) by double clicking on a sis file?



  • Yes, I can install applications using .sis files (e.g. public coda installer) I chose PC Suite Mode upon connecting the usb cable on device. It's weird when Qt Creator shows no error while running the application on device but when the application is already installed on phone and tried running it, nothing happens :(



  • The application output shows this error:

    @
    Launch failed: Command answer [command error], 1 values(s) to request: 'C|7|Processes|start|""|".exe"|[""]|[]|true'#0 {"Code":-1,Format="

    Failed to create the process (verify that the executable and all required DLLs have been transferred) (item not found)"}Error:

    Failed to create the process verify that the executable and all required DLLs have been transferred item not found@



  • I tried using TRK instead of CODA (thinking it might resolve the problem), now i have this application output:

    "Executable file: <non-existent> C:\Users\Tracey
    Starting application...
    Could not start application: General OS-related error
    Finished."

    Now what should I do?

    Sorry for asking so many questions. I just really need to deploy this application on device successfully



  • On more idea: are you creating the smart installer for the application when you try to debug it? It probably does not have anything to do with this issue but I have had issues running the application on the device when using the smart installer.

    If you can't make any progress I suggest you remove from your phone your developer certificate, coda, your application and then start over...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.