⚠️ Forum Maintenance: Feb 6th, 8am - 14pm (UTC+2)

[SOLVED] Trying to Run GlovePIE with parameters

  • I am trying to open GlovePIE with a script already loaded. Via command line this can be easily accomplished by (while in the correct folder) calling "GlovePIE.exe scriptname.PIE". However, when trying to get this to run on a button press using:
    void MainWindow::runGlovePIE()

    This just opens the program, but any attempts I've made to open it with extra parameters (even with answers from this forum have not succeeded). Any suggestions?

  • Nevermind, problem solved.

    "GlovePIE.exe scriptname.PIE" didn't work because it couldn't find the file because when runnning the debug version, the working directory was not the same as the .exe as it is when one would normally run the .exe

  • Did you try "startDetached with parameter list":https://qt-project.org/doc/qt-4.8/qprocess.html#startDetached-2 ?

  • Try using a parameter list.
    QStringList params << "scriptname.PIE";

    Edit: Nevermind. I missed the part where you said you'd figured it out. :)

  • Thanks for the responses anyway, I do love the response time here =D. This definitely seems like a flaw with the way Qt does stuff because debug behavior does not simulate actual behavior.

  • Glad to (try to) help! Be sure and edit your post to mark it [Solved]. Thanks!

  • Done, thanks for the reminder!

Log in to reply