ANN: A new version of the Qt SDK for iOS is now available.



  • The SDK contains Qt 4.8.1, QtMobility, Qt3D, QtGameEnabler, QmlViewer, MatchEmPoker & OpenSSL. The SDK package contains OpenGL/ES 1.x (for legacy devices) and OpenGL/ES 2.x distributions for device and simulator.

    The MatchEmPoker sample (included) can be used as an example of how to build a QtGameEnabler app for iOS (look at the .PRO file).

    To see Qt4iOS in action, download the SDK, install the GLES2 version and open the 'qmlviewer' project in Xcode.

    For more information: https://twitter.com/#!/Qt4iOS/status/194212403083345921

    (unfortunately this forum corrupted the download links so they were removed)



  • sounds nice! i will give it a try!



  • This SDK is not officially (or unofficially) endorsed by Nokia, Digia or anyone else. It has been built from the released Qt4.8.1 OpenSource source code with the necessary API changes to Qt4.8.x patched in. The source code is provided as a separate download.

    As there are changes required (particularly for OpenGL) that can't make it into 4.8.x due to that API being 'frozen', the 'branch' of Qt4.8.x will be maintained in gitorious as 'qt-ios-plaszma'.

    The SDK contains two 'Lighthouse' http://labs.qt.nokia.com/category/labs/lighthouse plugins for iOS: 'iOS' (commercial, developed with a commercial Qt license, closed source) and 'UIKit' (open source, part of Qt 4.8.x).



  • [quote author="Qt4iOS" date="1335146161"]
    The MatchEmPoker sample (included) can be used as an example of how to build a QtGameEnabler app for iOS (look at the .PRO file).
    [/quote]

    when trying to make this sample I get
    @
    In file included from /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/bits/c++locale.h:50,
    from /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/iosfwd:45,
    from /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/bits/stl_algobase.h:70,
    from /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/algorithm:65,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qglobal.h:68,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qnamespace.h:45,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qobjectdefs.h:45,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qobject.h:47,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qcoreapplication.h:45,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtGui/qapplication.h:45,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtGui/QApplication:1,
    from src/main.cpp:5:
    /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/cstdarg:51:20: error: stdarg.h: No such file or directory
    In file included from /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/iosfwd:45,
    from /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/bits/stl_algobase.h:70,
    from /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/algorithm:65,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qglobal.h:68,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qnamespace.h:45,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qobjectdefs.h:45,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qobject.h:47,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtCore/qcoreapplication.h:45,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtGui/qapplication.h:45,
    from /Developer/Qt4iOS/qt-everywhere-ios-gles1-4.8.1/include/QtGui/QApplication:1,
    from src/main.cpp:5:
    /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/bits/c++locale.h: In function ‘int std::__convert_from_v(int* const&, char*, int, const char*, ...)’:
    /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/bits/c++locale.h:77: error: ‘va_start’ was not declared in this scope
    /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/include/c++/4.2.1/bits/c++locale.h:85: error: ‘va_end’ was not declared in this scope
    @

    any thoughts why ? my xcode is 4.2 , in order to run on iOS 5.1 I've added manually iOS 5.1 to related folders, (iOS5.1 apps work ok), I've followed your guides from/and 18 Apr SDK. thx for any help,



  • on simulator started with gles2, but on device to compile as you see above, also I've used for device gles1, going to try again but seeing the watermark screen on simulator and mediator site seems to be dead with no contacts, where I can find out how much the license costs ?



  • For starters Matchem Poker is OpenGL/ES2.x only, so it won't work if you're building it with a OpenGL/ES1.x SDK anyway... Then patching unsupported SDKs into Xcode is not going to make life any easier. Use Xcode 4.3.x or one of the SDKs supported by Xcode 4.2.x. Nothing in the Qt4iOS SDK uses any feature from iOS that requires a later SDK than iOS 4.0.

    Due to the costs involved, the Qt4iOS 'iOS' platform plugin is not suitable for end users at this time. It's possible to use the 'UIKit' plugin and the SDK for free (LGPL), but that plugin does not support OpenGL, GameEnabler etc., so you'd need to extend it if you wanted to use those features...



  • I faced similar issue, and SOLVED it by adding llvm- to the gcc and g++ to the makefile as below

    [directry]/g++-4.2 change it to [directry]/llvm-g++-4.2
    [directry]/gcc-4.2 change it to [directry]/llvm-gcc-4.2

    note the only change is adding the "llvm-" in the makefile,



  • The SDK has been updated to Qt 4.8.4, and is available from:

    http://www.mediator-software.com


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.