Important: Please read the Qt Code of Conduct -

Compiling Qt Jambi for QT 4.8 fails

  • Greetings,
    I've cloned QT source code from git, and I've compiled it without any problems under Windows 7 64 bit, using Visual Studio 2008's compiler, again 64 bit.

    I've then cloned the jambi git repository, and followed instructions. Compilation began, and after about 20 minutes, it stopped with an error. The final bits of compilation output are here:

    Google searches for the errors, such as " cannot find symbol" leads to only one entry in pastebin. That makes me think that someone else tried the same thing, and they've also failed.

    Here is the last few lines of the output, just in case it rings a bell (the complete list of errors is in the pastebin page)

    @[javac] ^
    [javac] c:\work\data\cPP\jambi\git\build\generator\out\java\com\trolltech\qt
    \gui\ cannot find symbol
    [javac] symbol : class QTextObjectInterface
    [javac] location: class com.trolltech.qt.gui.QAbstractTextDocumentLayout
    [javac] if (!(component instanceof QTextObjectInterface)) {
    [javac] ^
    [javac] 19 errors
    [javac] 1 warning

    c:\work\data\cPP\jambi\git\antfiles\java.xml:66: The following error occurred wh
    ile executing this line:
    c:\work\data\cPP\jambi\git\antfiles\jar.xml:85: Compile failed; see the compiler
    error output for details.@

    Am I on the wrong track here? Is this a known issue?

    Best regards

  • You got this sorted via the mailing list and IRC ?

    For others reading this forum:

    Any build failures that list QFuture are usually because the ANT property "generator.includepaths" at the bottom of has not been configured.

    QtJambi builds against 4.8, 4.8.1 and probably any future 4.8.x if/when those releases arrive.

  • Yes, I've completely forgotten about writing it here. This is indeed the solution. The comments in the kinda confused me, I thought setting the QTDIR variable would configure everything but that was not the case.

    Thanks for writing the solution here.

Log in to reply