Qt 4.8.1 on Windows CE



  • Have not been able to build Qt 4.8.0 with our Windows CE SDK and MSVC 2005, but was hoping for 4.8.1 to work better.
    It doesn't. It currently gets to the 3rd party library zlib, which it fails to compile with a bunch of similar errors, e.g.:

    @
    c:\p4ws\balthazar\camera\apps\main\qt\4.8.1-bacx\include\qtcore../../../4.8.1/s rc/corelib/kernel/qfunctions_wince.h(80) : error C2085: 'qt_wince_getenv_s' : not in formal parameter list
    c:\p4ws\balthazar\camera\apps\main\qt\4.8.1\src\3rdparty\zlib\gzguts.h(82) : error C2085: 'gzopen64' : not in formal parameter list
    @

    Has anyone else had this problem, and found a way to solve it?



  • I'm encountering the same issue, I'll try to fix it by my self if I can.
    Have you already found something?

    My current configure command is :
    @configure -release -opensource -fast -nomake examples -nomake demos -no-qt3support -no-webkit -no-phonon -no-dbus -no-script -no-scripttools -no-multimedia -platform win32-msvc2008 -xplatform wince50standard-armv4i-msvc2008 -D QT_NO_DRAGANDDROP -D QT_NO_CLIPBOARD -D QT_NO_CURSOR@



  • Same issue.
    I'm getting the following error.
    @
    c:\qt\4_8_1\src\3rdparty\zlib\gzguts.h(82) : error C2085: 'gzopen64' : not in fo
    rmal parameter list
    c:\qt\4_8_1\src\3rdparty\zlib\gzguts.h(83) : error C2085: 'gzseek64' : not in fo
    rmal parameter list
    c:\qt\4_8_1\src\3rdparty\zlib\gzguts.h(84) : error C2085: 'gztell64' : not in fo
    rmal parameter list
    c:\qt\4_8_1\src\3rdparty\zlib\gzguts.h(85) : error C2085: 'gzoffset64' : not in
    formal parameter list
    @
    Used the following command.
    @
    C:\Qt\4_8_1>configure -platform win32-msvc2005 -xplatform wince60cellnovo-armv4i-msvc2005 -stl -vcproj

    C:\Qt\4_8_1>configure -platform win32-msvc2005 -xplatform wince60cellnovo-armv4i
    -msvc2005 -stl -vcproj@



  • Solved this issue.

    Add following lines to 3dparty\zlib\gzguts.h :
    @
    #define open qt_wince_open
    #define close qt_wince__close
    #define lseek qt_wince__lseek
    #define read qt_wince__read
    #define write qt_wince__write
    @
    Before
    @
    #include <qglobal.h>
    #include <qfunctions_wince.h>
    @
    In corelib/kernel/qfunctions_wince.h change this
    @
    #ifdef QT_BUILD_CORE_LIB
    QT_MODULE(Core)
    #endif
    @
    with following (add semicolon)
    @
    #ifdef QT_BUILD_CORE_LIB
    QT_MODULE(Core);
    #endif
    @
    And remove Zlib specific section because it was just moved to gzguts.h
    @
    #ifdef ZLIB_H
    #define open qt_wince_open
    #define close qt_wince__close
    #define lseek qt_wince__lseek
    #define read qt_wince__read
    #define write qt_wince__write
    #endif
    @
    Best of luck



  • Thanks a lot for sharing the info!!!
    It's working like a charm now!

    Any idea about what's wrong with the QT_MODULE(Core); ?
    In other files, they also don't use a ";"



  • No prob.

    Unfortunately I have no idea why it did not compile w/o of semicolon.
    It could be the problem with VS compiler or some kind of issue induced by other defines.

    My primary target was to make it build ;-)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.