[resolved] somehow I messed up my tool chain...



  • ...I was/am trying to use new versions of g++ and gdb. Somewhere along the lines, I must have fouled something up, because now I can't build my GDB helper. I get this message:

    @Building helper(s) with toolchain 'GCC (x86 64bit)' ...
    Building helper 'GDB helper' in /Volumes/1_TB_HD/Users/mzimmers/Library/Application Support/Nokia/QtCreator/qtc-debugging-helper/230550687/

    Running /Developer/Applications/Qt/Desktop/Qt/4.8.0/gcc/bin/qmake -spec macx-g++ dumper.pro -nocache CONFIG+=x86_64 ...

    Running /usr/bin/make all -k ...
    Error running '/usr/bin/make all -k' in /Volumes/1_TB_HD/Users/mzimmers/Library/Application Support/Nokia/QtCreator/qtc-debugging-helper/230550687/: The process returned exit code 2:
    g++ -c -pipe -g -gdwarf-2 -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.5 -Wall -W -fPIC -DUSE_QT_GUI=1 -DQT_GUI_LIB -DQT_CORE_LIB -I/Developer/Applications/Qt/Desktop/Qt/4.8.0/gcc/mkspecs/macx-g++ -I. -I/Developer/Applications/Qt/Desktop/Qt/4.8.0/gcc/lib/QtCore.framework/Versions/4/Headers -I/Developer/Applications/Qt/Desktop/Qt/4.8.0/gcc/include/QtCore -I/Developer/Applications/Qt/Desktop/Qt/4.8.0/gcc/lib/QtGui.framework/Versions/4/Headers -I/Developer/Applications/Qt/Desktop/Qt/4.8.0/gcc/include/QtGui -I/Developer/Applications/Qt/Desktop/Qt/4.8.0/gcc/include -I. -F/Developer/Applications/Qt/Desktop/Qt/4.8.0/gcc/lib -o dumper.o dumper.cpp
    make: g++: No such file or directory
    make: *** [dumper.o] Error 1
    make: Target `all' not remade because of errors.
    Build failed.@

    If I understand this correctly, it's looking for dumper.o, but not finding it. Shouldn't it just be rebuilding it from dumper.cpp?

    Thanks.

    EDIT:

    A bit more information: I went to the dumper directory and tried to run make there manually. Got this error:
    @++: error: unrecognized command line option '-Xarch_x86_64'
    @

    Any idea on this one?


  • Moderators

    Which compiler are you using?

    I think (not a mac user!) that apple ships patched versions of gcc which support switching of architectures using command line switches not available by a vanilla gcc. You will need to use a custom mkspec if that is indeed the case.



  • Well, currently I'm trying to use g++-4.2. I'm going to reinstall XCode and see what happens. I'll report back in a bit.



  • OK, I reinstalled XCode; no change. I've noticed a couple other oddities which may or may not be related to all this:

    1. My Qt Creator About page says it's based on Qt 4.7.4 (64 bit). Is this true, or possibly an artifact? I thought I'd downloaded the latest and greatest.

    2. Just for the exercise, I decided to re-install Qt. The online installer gives me this error message:

    bq. You need a C++ compiler to be able install the Qt SDK. Please install the latest Xcode first before invoking this installer

    I have the latest version of Xcode available to my OS (10.6.8). I've even gone so far as to remove the gcc47 I installed recently. What do I have to do to tell the installer that I have a compiler?

    Somehow, I suspect MacPorts is behind all this...



  • Update: I've re-installed XCode and Qt. Almost everything is OK now, but when I try to build the debugging helper, I get an error that it can't delete a directory under my user space. If I manually delete the directory, it removes the Qt version selection from my build settings. When I select the version again, it removes the debugging helper.

    What am I doing wrong NOW?

    Edit: after some more experimentation, it appears possible that this problem came from mis-use on my part. When I clear the directory in question, the build seems to succeed. If I push "build" a second time, though, that's when the errors occur. If this sounds feasible to more knowledgeable users than I, then I'm willing to eat this one, though I'd point out that the "build" button should survive what effectively amounts to a rebuild (IMO).

    I'd like to get some feedback from the smarter folks here before I mark this as solved.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.