Preferred debugger is not available



  • I recently got a new computer and downloaded the new Qt SDK version 1.2 through the online installer. I have an existing project buil on a different computer with version 1.1 ( I think) I tried to debug my project and I got the error message "None of the debugger engines ‘Cdb engine, Gdb engine’ capable of debugging binaries of the type ‘x86-windows..." I can't debug but the program will build and run. I am running Windows 7. I looked in the forums but got conflicting info. One area it states that you need to download Microsoft debugging tools and another area it says that the SDK will install GDB debugging tools??? What do I need to do to get this to debug?


  • Moderators

    You do not need necessarily ms debugging tools.

    I would recommend to start with a small "hello world" program on your new installation of Qt SDK 1.2. Make sure that you are doing a debug build and try to start the debugger.

    If this works alright you can start seeing the issues of the inheritated project.



  • I started from scratch and made a dialog with a button on it, Tried to debug and same error


  • Moderators

    Did you built for debugging?

    Have a look under "projects" the build toolchain is given. At the top it tells you whether you are in debug or release.



  • The build settings are Qt 4.8 for desktop-MinGW (QtSDK)
    The QT Version is Qt 4.8 for desktop-MinGW (QtSDK)
    The tool chain is Mingw as a gcc for windows targets
    In the QMake file there is qmake.exe Autopost.pro -r -spec win32-g++ "CONFIG+=declarative_debug"
    I looked at the Tool chains in the Buid and Run Options and it shows in the auto detected section Mingw as a gcc for windows targets
    The compiler path shows C:\QtSDK\mingw\bin\mingw32-g++.exe
    The ABI shows x86-windows-msys-pe-32bit
    The debugger field is blank but the browse button is disabled.
    I think that could be the problem, but how do I put in the path for the debugger and which one?


  • Moderators

    The settings are similar in my installation. The difference I saw is the "CONFIG+=declarative_debug". I do not have this. I do not know, what it is for. You might want to remove it for a trial.
    Unfortunately, I am of no further help.


  • Moderators

    poporacer: If the debugger field is blank then most likely something went haywire during the installation.

    Try this: Go to Tools->Options->Build & Run->Tool chains and clone the mingw toolchain that creator has detected. In the cloned copy you can edit the fields, so you should be free to enter the debugger found in python-gdb of your SDK installation (IIRC in the bin subfolder, not sure, I am not running windows regularly:-).

    You will not need the microsoft debugging tools: Those are required for binaries generated using the MSVC compilers and do not work with mingw binaries.



  • Thanks Tobias,
    That is what I did as a work around. I wasn't sure why it wouldn't work out of the box. I tried uninstalling and then re installing but it still came up with the debugger as blank.


  • Moderators

    You could "file a bug report":http://bugreports.qt-project.org/ against the Qt SDK.

    If the debugger is installed as part of the SDK then it should be picked up by the Qt Creator provided by the same SDK.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.