⚠️ Forum Maintenance: Feb 6th, 8am - 14pm (UTC+2)

[SOLVED] Qt Mobility / Service framework / Insufficient credentials to load a service instance / InvalidServiceLocation

  • Hello,

    i've been stuck for some hours with this issue while trying to implement a simple example to use the service framework of Qt Mobility with two processes.

    First process was registering the service itself, second process was a client that tried to get the interface of the remote service and performed a call to a given method.

    When the client process was basically performing a "loadinterface" with a service descriptor it simply kept failing returning error 2 : InvalidServiceLocation and the output terminal showed a "Insufficient credentials to load a service instance" message.

    I finally found out what was the issue in the end. I had a mismatch between the name of my interface in my service XML file (eg com.nokia.examples.sfw.MyService) and the name I used in the service process while registering the remote service using the createEntry call, I had a different name here.
    This difference in names led to the issue.

    Hopefully this post will help other persons too, because I did not find any other online help refering to this "Insufficient credentials to load a service instance" message anywhere!


  • Thanks a lot for sharing your experience.

  • Hi, i found that error 2 is 'The service was not found at its specified location' not 'Insufficient credentials to load a service instance' from "doc":http://doc.qt.nokia.com/qtmobility-1.2/qservicemanager.html Where you read that?

    i found the 'error' the message is from "here":http://qt.gitorious.org/qt-mobility/simulator-mobility/blobs/aef279aed9954ac48bf7e033e277ad88a29cb5fb/src/serviceframework/ipc/qremoteserviceregister_dbus_p.cpp#line298 and this is another error message not link with the previous one. You're confused the two differente error :)

    Ps: I think service in mobility is based on dbus, and for me the most frequent error is a bad called slot after a different declaration on xml interface :)

Log in to reply