How to run application binary on Target?



  • Hi, I have a simple code and compiled with qmake and make.
    Please note that I am working and doing this on for a target.
    After getting a binary, I try to run it as the same as we do with the fluidlauncher demo [ I have installed Qt_every_where_opensource_4.7.4 ].

    But it will not work leaving me with
    @post4pavan@ubuntu:~/Work/hi$./hi
    /lib/ld-linux.so.3: No such file or directory@

    when I run this application.
    I place this in folder with application in my rootfs folder which contains /usr/local/Trolltech/Qt-target-version/hi and run it, but still I get the same error

    1.Where should be application binary placed so that I can make it run on
    a. PC &
    b. Desktop
    2.Is it that, I am running this application separately and is a reason that it's not working?

    Please suggest. :: Krishna Pavan


  • Moderators

    Looks like the build machine and your target machine are not compatible. How did you build your executable?



  • Hi, Thank You, Tobias Hunger!

    I ran a qmake, that's prepared for target i.MX5X from freescale, using Qt_Opensource_4.7.4.
    My host machine is 64-bit, Intel, machine, running Ubuntu 10.04.

    I ran as instructed "here":http://developer.qt.nokia.com/forums/viewthread/14429 I got succeded in getting an executable(application/x-executable)


  • Moderators

    Hey, in that thread I just told you where to not run qmake:-) That has nothing to do with building for a different platform!

    Do you have a mkspec you need to use for your target machine? Do you have a sysroot (a copy of the machine's filesystem with added headers, etc.) to build in/against?



  • Hi,

    Yeah, I was completely aware of the cross-compilation.
    In that post, I need to use the qmake in my project folder and not in the filesystem folder, that was actually a mistake.
    The method I followed is correct and has got me a correct makefile with all the cross-compilers&paths required. I have double checked that.

    I am sure that I have used a specific spec file that's intended for i.MX.
    I have also copied the libararies and they are present in my rootfs. That's perfect.

    So, getting the executable was correct with a correct procedure.

    I have run the demo using Qt_SDK_Simulator, got a proper makefile and executable, with support of compilers & libraries installed on Host.

    Problem is with the executable running on specified target.

    Regards :: Krishna Pavan


  • Moderators

    The Qt Simulator is not emulating the target hardware (it is a simulator, not a emulator for a reason;-). So you can not run the executable that works with the simulator on your device.



  • Hi, Thank You, Tobias Hunger!

    yeah, probably I should use QEMU and use the executable in an environment that should be...

    Regards :: Krishna Pavan


  • Moderators

    If at all possible go for a cross-compile environment in favor of running the complete build inside an emulator: Cross-compiles are much faster.

    Down side is that many projects have broken configuration scripts that fail in cross-compiler environments:-(


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.