Important: Please read the Qt Code of Conduct -

[Solved] QtDesigner will not load a plug-in even when I try to Force it

  • Hi I'm having a problem getting QtDesigner to load a particular plugin. I'm using Arch Linux (64-bit) with Qt 4.8.0-2 from Arch Linux's repository. The QtDesigner version is 4.8.0

    The Steps I followed:

    1. I built and installed the VTK library (Debug build) ( "": ) with QT support. The library provided a widget "QVTKWidget" with an associated plugin for QtCreator.

    2. The plug-in resides at

    3. In a terminal I ran
      $ export QT_PLUGIN_PATH=/usr/local/plugins/designer/
      $ export QT_DEBUG_PLUGINS=1
      $ designer

    Then I go to "Help > About Plugins" and QVTKWidget is not there. The debug output shown by the QT_DEBUG_PLUGINS option does not show any attempt to load the library.

    But if I try
    $ export QT_PLUGIN_PATH=/usr/lib/kde4/plugins/
    $ designer

    Then QtDesigner will load KDE's plugins and I can see its widgets.

    I found a way to get QtCreator to load the "QVTKWidget" plugin which is by making a symbolic link to the library in Qt's plugin directory...
    $ ln -s /usr/local/plugins/designer/ /usr/lib/qt/plugins/designer/
    $ export QT_DEBUG_PLUGINS=1
    $ designer

    The debug output doesn't show that the plugin was loaded which is weird, however when I go to "Help > About Plugins" I can see "QVTKWidget". This method unfortunately isn't acceptable because I don't have root access on the machine that I will be doing development on.

    Does anyone know why I can't force QtCreator to load the "QVTKWidget" plugin?

  • I appeared to have fixed my own problem. It appears that QtDesigner looks requires there to be a "designer" folder in the path in in QT_PLUGIN_PATH . So I should of done

    $ export QT_PLUGIN_PATH=/usr/local/plugins/

    instead of

    $ export QT_PLUGIN_PATH=/usr/local/plugins/designer/

    Problem solved :)

  • Thank, but what is the PATH that works for Windows?

Log in to reply