Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

cannot find -lqbspkgconfig



  • I'm trying to compile Qt Creator 6.0.1 from offcial release from download.qt.io with MinGW-w64(GCC10.2.1).
    I followed the guide of other's document, only qmake and make.
    After waiting for a long time, I finally get a error message.:cannot find -lqbspkgconfig.
    The command above is
    "Entering directory 'F:/creator/qt-creator-opensource-src-6.0.1/src/shared/qbs/src/lib/corelib'
    g++ -Wl,-s -shared -Wl,-subsystem,windows -mthreads -Wl,--out-implib,F:\creator\qt-creator-opensource-src-6.0.1\lib\qtcreator\libqbscore1.a -o ............\lib\qtcreator\qbscore1.dll @object_script.qbscore.Release -LF:\creator\qt-creator-opensource-src-6.0.1\lib\qtcreator F:\creator\qt-creator-opensource-src-6.0.1\lib\qtcreator\libqbsscriptengine1.a -lqbspkgconfig -lstdc++fs -lpsapi -lshell32 F:\Qt\6.0.0\mingw81_64\lib\libQt6Core5Compat.a F:\Qt\6.0.0\mingw81_64\lib\libQt6Network.a F:\Qt\6.0.0\mingw81_64\lib\libQt6Xml.a F:\Qt\6.0.0\mingw81_64\lib\libQt6Core.a release\qbscore_resource_res.o"
    I search for long time, only few message has nothing to do with my problem.
    Any solutions?


  • Lifetime Qt Champion

    @Hu-Junhao Looks like you're using Qt6.0.0?
    I suggested to use latest official Qt6 release.
    Also, do you really need to build QtCreator by yourself?



  • You're right,I'm using Qt 6.0.0.
    I want to create a Qt Creator Plugin, but I really don't know how to choose the build Qt Creator build, until I found this topic"https://forum.qt.io/topic/132496/wizard-made-creator-plugin-builds-fail".
    The solution seems like I need to build Qt Creator by myself. I'm not sure whether it's neccessary.


  • Lifetime Qt Champion

    @Hu-Junhao said in cannot find -lqbspkgconfig:

    The solution seems like I need to build Qt Creator by myself

    Not really. You need to use exact same Qt version like the one used to build QtCreator. Open the "About QtCreator" dialog and you will see which Qt version was used to build it.



  • Thanks, I'll try.



  • In order to build Qt Creator plugins you don't need to build Qt Creator itself. Unless you are using a compiler that is not used to build the official Qt Installations.

    For example, you only need to select the Qt Creator 6.0.2 Plugin Development checkbox in the installer.

    qtcreator-plugin-development.png ![alt text](image url)

    If you decide to build Qt Creator yourself, please note that the CMake build system is being officially supported to build Qt Creator.


Log in to reply