Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QT Creator 6.0.1 Design view not working



  • Hi all. I'm using PClinuxOS latest 64bit ver fully updated. Using the synaptic package manager I installed the available Qt 5.12.12 version along with Qt creator 5.0.3 . No matter what I tried following every online suggestion I couldn't get the examples to show up on the welcome page.

    In desperation I eventually uninstalled and used the Qt online installer to install Qt and Qt Creator ver 6.0.1 The examples showed up and my previous projects worked but no matter what I tried I couldn't get it to go into design view.

    Once again I uninstalled and following another link found offline installer for Version 5.12.12 . This version works! Both examples and design view are working.

    It would seem that my distro version has issues with the way it is installed because the offline install of the same version from Qt works. More worryingly the latest version 6.0.1 seems to have a bug stopping access to the design view with the same projects that work fine on the 5.12.12 version. Any thoughts would be appreciated.



  • @PaulS01 Latest Update. I know I'm new to QT but I have been a programmer for the best part of 40 years. Modern IDE's make life so much easier in many ways. But the learning curve to use the IDE can be greater than the differences in language modules. Particularly when logic doesn't seem to have been applied.

    It turns out the reason that I couldn't get into QT designer is it was disabled by default!! Why is it disabled by default? I couldn't find anything in documentation or online about this.

    To enable Qt designer you need go into Help then About Plugins... This doesn't, as you would think, open any sort of help but instead opens a dialogue allowing one to enable, disable or install plug-ins. I didn't even realise Qt Designer is a plug-in! What is the Logic behind this? There is a perfectly good Tools menu item with an "Options" choice at the bottom.

    Qt is such a good package I find it hard to understand how things like this happen. Making it particularly difficult for new users, often resulting in many hours of wasted time.

    As for Examples. Yes they are accessible but QT's version control seems to leave a lot to be desired particularly when it comes to QT quick. Many examples fall over just because they are trying to include the wrong version. Ive discovered the variations in functionality in QT quick versions has some pretty hard to understand effects on the behaviour of my code. I'm sure that it is probably mainly my fault for not reading reams of documentation but again that also detracts from getting the job in hand done.

    Currently I'm having difficulties getting to the bottom of inconsistent file access behaviour for images in QLM. In that it is inconsistent between versions of Qt Creator. In ver 6.0.1 I can't get anything but a full path to work "file: /home/project/somefile.img" works when I run the routine.
    "home/project/somefile.img" fails resulting in (QML Image: Cannot open: home/project/somefile.img).
    "qrc:/home/project/somefile.img" fails resulting in (QML Image: Cannot open: qrc:/home/project/somefile.img).
    "/project/Somefile.img" is of course not the name of the file I'm actually using.

    Moving a project between Qt Creator/Qt versions also resulted in some very strange behaviour of the design view. Although the project executed fine. The design view did strange things with images until I removed and reinstated them from assets. Just entering design view executed the project multiple times at one point, popping up several windows for no reason. So I'm suspicious of the design view and the way in handles images. Or is it just me being a Donkey???



  • @PaulS01 How did you install Qt Creator? All you described is not true under Windows/macOS/Debian/Ubuntu so I gather it must be specific to your version of OS.



  • @artwaw Hi I have installed the Synaptic version that comes with PClinuxOS (Debian Based) No examples but everything else seems to work.
    Then Installed version 6.0.1 from the Qt website using the online installer. Design view disabled but not documented.
    Then intalled Version 5.12.12 using the offline installer downloaded from Qt web site. But some problems with Qt quick version as it seems to need include statement for ver 2.3
    Then tried ver 6.0.1 again from online installer. Found the option to enable design view but found that includes have to be either for ver 2.15 or 2.4. I understand this all depends on what kit is used



  • @PaulS01 well, yes. In my personal experience mixing prepackaged apt versions on the ones from online installer tends to mess things up due to config conflicts, I experienced that myself. Clean uninstall before trying new source seems to solve the problem.

    If you intend to have multiple Qt versions (5.x and 6.x for example) that is possible without much of a problem, with Qt Creator though things can get dicy.



  • @artwaw No you misunderstand I have only had one version installed at any point and the examples I'm referring to are the ones included with that install. I only want to have one version that works. QTquick version numbers can be omitted form Qt6 which makes sense but file references still don't work as expected.



  • @PaulS01 said in QT Creator 6.0.1 Design view not working:

    It turns out the reason that I couldn't get into QT designer is it was disabled by default!! Why is it disabled by default? I couldn't find anything in documentation or online about this.

    At https://www.qt.io/blog/qt-creator-6-released we can read:

    The integrated Qt Quick Designer is now disabled by default. Qt Creator will open .ui.qml files in Qt Design Studio. This is a step towards a more integrated workflow between Qt Design Studio and Qt Creator (video). Qt Quick Designer is still there, you can manually enable it again by checking the QmlDesigner plugin in Help > About Plugins.



  • @Crisian-Adam-0 what

    I believe that my definition of the word "integrated" is somewhat different. Obviously I could not notice since I don't remember when I was installing Qt from scratch.


Log in to reply