Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Need help on QDialog behavior in Mac



  • I am using:
    Mac OS: 10.15, 11 and 12
    Qt: 5.15.2
    Note: Sorry, but I am unable to create a sample application for this problem. I will post if I could create one.
    I have a main window from which I am launching a QDialog. In QDialog, I have few tooltip enabled for child widgets.

    Issue I m facing:

    For the first time when I am launching the Dialog, I am able to see all the tool tips. But once I close the dialog and launch it again, the tooltips are not appearing anymore.
    An second launch of the dialog, if I am clicking on the dialog or moving mouse pointer out of the dialog and bringing in again, then I am able to see the tooltips again.
    Just taking the mouse pointer to the title bar close button and bringing back the pointer inside the dialog also enabling the tooltips.
    This issue I am not seeing in Windows (tested on Windows 10).

    Please let me know, if you have any suggestoin for me on this issue.


  • Lifetime Qt Champion

    Hi,

    @BikashRDas said in Need help on QDialog behavior in Mac:

    Note: Sorry, but I am unable to create a sample application for this problem. I will post if I could create one.
    I have a main window from which I am launching a QDialog. In QDialog, I have few tooltip enabled for child widgets.

    In that case, remove all the code unrelated to that dialog. In the dialog remove everything not related to the tooltip.

    With all that removed, you should have something close to a minimal example.


Log in to reply