Important: Please read the Qt Code of Conduct -

Unable to Build and Run Project

  • Hello Everyone,
    I am facing a problem with building and running the Qt Projects.
    I created a new qmake project and I am getting errors, so I thought I might have done something wrong, after that, I took the example projects and none of them are working.
    The following is the error that I am getting.

    13:29:55: Running steps for project chartthemes...
    13:29:55: Starting: "/home/xpress_embedo/Applications/Qt/6.2.2/gcc_64/bin/qmake" /home/xpress_embedo/Applications/Qt/Examples/Qt-6.2.2//charts/chartthemes/ -spec linux-g++ CONFIG+=debug CONFIG+=qml_debug
    13:29:56: The process "/home/xpress_embedo/Applications/Qt/6.2.2/gcc_64/bin/qmake" exited normally.
    13:29:56: Could not start process "make" -f /home/xpress_embedo/Applications/Qt/Examples/Qt-6.2.2/charts/build-chartthemes-Desktop_Qt_6_2_2_GCC_64bit-Debug/Makefile qmake_all.
    Error while building/deploying project chartthemes (kit: Desktop Qt 6.2.2 GCC 64bit)
    When executing step "qmake"
    13:29:56: Elapsed time: 00:00.

    From the message, it looks like that there is some issue with the Kit, and below is the screenshot of my kits.
    Qt Kit Problem.png

    From the above screenshot, it is clear that I am missing a kit based on Qmake, and tried to add a new one but couldn't add it.
    I found this link and based on this link tried to add the kit but couldn't find the qmake option here.
    Settings Filter.png

    But when I created a new project with Cmake it works fine, which I understood because the kit based on the CMake is installed.
    I know that now Qt will be using Cmake and I am okay with it, but how to build old projects and example projects. Can someone help me in resolving the issue? Thanks in advance.
    I am using Ubuntu 20.04.3 and
    QT Version.png
    This is a fresh install of Qt using an online installer.

  • Sorry for this stupid question, I am able to solve the issue.
    The problem was that "make" was not installed, I didn't expect this that make is not installed, so after installing make everything is working fine. Thanks

Log in to reply