Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtCreator does not start from "Favorites" in Ubuntu 20.04 LTS



  • Hi,
    I have installed QtCreator 4.11.0 (based on Qt 5.12.8) on Ubuntu 20.04 LTS. When I start it in terminal, the green icon with "QC" is shown in Taskbar (or whatever is called). I then click right on icon and select "Add to Favorites". When I try to start QtCreator from that Ican (on Taskbar) it doesn't start. When I start it in terminal with qtcreator, it starts normally.
    I also activated debug flag with export QT_DEBUG_PLUGINS=1, but no error is shown in Terminal (yes, I start it from the Terminal, where I set the environment variable).
    What is the problem?
    Thanks.



  • Which desktop are you using? KDE? Gnome? Most likely the "add to favorites" function doesn't set the full path or tries to start qtcreator in a terminal window. If you run KDE, launch kmenuedit and create a new entry for QT Creator. If you use the full path to the executable and you do not activate the "run in terminal" option, it should start just fine and you can add the menu entry to your favorites later.



  • Ok, I solved my problem. OpenGL library was not installed.
    I looked at the journal with journalctl -f and saw the line:

    /usr/bin/qt/Tools/QtCreator/bin/qtcreator: error while loading shared libraries: libOpenGL.so.0: cannot open shared object file: No such file or directory
    

    Then I installed it with sudo apt install libopengl0 -y, it works now.


Log in to reply