N9 deployment problem



  • Hi,

    I used to be able to deploy my Qt Quick app built in Qt Creator to my N9 without any problems, but now it just won't work.
    In the Compile Output window, I get this:
    @
    dh_gencontrol
    dpkg-gencontrol: warning: unknown substitution variable ${shlibs:Depends}
    dpkg-gencontrol: warning: unknown substitution variable ${misc:Depends}
    dh_md5sums
    dh_builddeb
    Can't exec "md5sum": Bad file number at /madbin/dh_md5sums line 62.
    aegis-manifest: No findings in 'camguiapp'.
    Can't exec "sha1sum": Bad file number at /madbin/gendigsigsums line 50.
    execve() failed: Bad file number
    @
    So it seems like it could be a problem with the Madde toolchain.
    Has anyone else seen this or had a similar problem, and know how to solve it...?

    I am running the latest SDK (on 64 bit Windows 7) and the version that worked might have been an older one.
    Also, I have installed the PR1.1 update on my N9.



  • Tried some other projects, including creating minimal new Qt Quick and Qt Widget projects, but I still cannot deploy to my phone. Seems not to have anything to do with the warnings in the Compile Output window, though, since I get different warnings for different projects. The package seems to be built, but cannot be deployed. The log in the Compile Output window ends like this:
    @
    23:25:52: Package Creation: Running command 'c:/qtsdk/madde/bin/mad dh_clean'.
    23:25:53: Package created.
    23:25:53: Installing package to sysroot ...
    23:25:53: Preparing SFTP connection...
    23:25:54: Starting upload...
    23:25:55: Failed to upload package: Failure
    23:25:55: Deploy step failed.
    Error while building project MTest (target: Harmattan)
    When executing build step 'Deploy Debian package via SFTP upload'
    @
    Any help on this would be most appreciated.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.