Qt World Summit: Submit your Presentation


QSslSocket cannot resolve errors



  • I recently started rebuilding old (qt 5.9.8 based) apps on Fedora 34. Upon running the app I get the errors below. I've done some searching that suggests its SSL 1.x related, but the various recommended solutions don't feel right or apply. I use network manager for some HTTP POSTs, but that's all. (So https:// is in the URL)

    Some answers in this forum suggest removing DLL's (but I'm using Linux). I have installed Qt Creator using the web installer (not built from source). This OS has OpenSSL 1.1.1k FIPS installed. I'm hoping I don't have to build Qt Creator from source.

    Can someone explain how to fix this properly?

    qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks
    qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback
    qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback
    qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings
    qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
    qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init
    qt.network.ssl: QSslSocket: cannot resolve sk_new_null
    qt.network.ssl: QSslSocket: cannot resolve sk_push
    qt.network.ssl: QSslSocket: cannot resolve sk_free
    

  • Lifetime Qt Champion

    Qt 5.9 needs openssl 1.0


  • Lifetime Qt Champion

    Hi,

    To add to @Christian-Ehrlicher, OpenSSL 1.1, while a minor release is not backward compatible with OpenSSL 1.0.



  • Is it possible to add OpenSSL 1.0 alongside OpenSSL 1.1 (on Fedora 34) - I realize there may not be any Fedora gurus here...so generic linux question.

    Since I have to build using only features up to Qt 5.9.x for older OS's...what the solution?


  • Lifetime Qt Champion

    @ocgltd said in QSslSocket cannot resolve errors:

    Is it possible to add OpenSSL 1.0 alongside OpenSSL 1.1

    Try it out. I don't see why you should not be able to install two different library versions.


Log in to reply