Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How to install latest Qt5?



  • I run QtMaintenance Tool and was surprised - the button Skip is absent. When I click Next - progress bar appears and after several seconds red message "Failed to connect to server. Check your network connection and try again". I did not change anything in this tool settings - I just did not use it for 2-3 years. What should I change manually in this tool settings to connect with Qt servers and install 5.15.6 version? Or is it better just download separate installer and use it?


  • Moderators

    Installer had a major upgrade ~1 year ago. You need to uninstall Qt completely and install fresh using the newest installer.

    Qt 5.15.2 is last available to open source users. Qt 5.15.6 is the latest one available for commercial users. (in Qt 5 branch; Qt 6 has - so far - same availability for both)



  • @sierdzio said in How to install latest Qt5?:

    Qt 5.15.2 is last available to open source users. Qt 5.15.6 is the latest one available for commercial users.

    What?!... :-0
    But I must upgrade all my Android apps to API 30 and reassemble distribution packages from APK to Android Application Bundle (AAB) format before Nov 1. This is Google's requirement. I use LGPL for my apps distributed on Google Play. AAB is supported only in 5.15.6, isn't it? Or is it available in 5.15.2 too (option Build .aab exists in Project settings)?

    Another issue is with in-app sales. AFAIK it appeared only in 5.15.6. I want remaster my apps to use it instead of separate free-with-ads and paid-no-ads pairs. But this is not so urgent deal. Is it known when 5.15.6 will be available for LGPL developers?


  • Moderators

    @Gourmet said in How to install latest Qt5?:

    @sierdzio said in How to install latest Qt5?:

    Qt 5.15.2 is last available to open source users. Qt 5.15.6 is the latest one available for commercial users.

    What?!... :-0

    Qt Company's way of increasing sales, I'm afraid :/

    But I must upgrade all my Android apps to API 30 and reassemble distribution packages from APK to Android Application Bundle (AAB) format before Nov 1.

    That requirement has been announced a very, very long time ago.

    This is Google's requirement. I use LGPL for my apps distributed on Google Play. AAB is supported only in 5.15.6, isn't it? Or is it available in 5.15.2 too (option Build .aab exists in Project settings)?

    Both AAB and APK FAT builds are supported since Qt 5.14.

    "Build option" stuff - this is in Qt Creator, which is completely independent from Qt version and all Qt Creator releases are available to all licenses.

    Another issue is with in-app sales. AFAIK it appeared only in 5.15.6. I want remaster my apps to use it instead of separate free-with-ads and paid-no-ads pairs. But this is not so urgent deal.

    I have no idea what you mean, sorry. Is this about QtPurchasing? It's available in old releases AFAIK, not restricted to 5.15.6. I've never used it, though, can't help much here.

    Is it known when 5.15.6 will be available for LGPL developers?

    Never.



  • @sierdzio said in How to install latest Qt5?:

    You need to uninstall Qt completely

    Is this mandatory? Is it possible keep previous Qt5.12 installation for suddenly case but install 5.15.2 separately on same machine?


  • Moderators

    In your new installation you can select both Qt 5.12 and 5.15... and any number of other versions if you need.


  • Moderators

    Whether old and new installer can coexist though - I doubt it but surely you can try.


Log in to reply