Project file specifies CONFIG += debug_and_release but I can only build in release. What Gives?



  • What else do I need to do in order to get my project to allow me to build in debug mode?
    @Qt Creator 2.4.0
    Based on Qt 4.7.4 (64 bit)
    Built on Dec 20 2011 at 11:14:33
    From revision b0b0842b03
    Copyright 2008-2011 Nokia Corporation. All rights reserved.
    @

    And my project file is as follows:

    @#-------------------------------------------------

    Project created by QtCreator 2011-08-31T13:11:51

    #-------------------------------------------------

    QT += core gui opengl
    TEMPLATE = app
    CONFIG += debug_and_release
    CONFIG(debug, debug|release){
    TARGET = ArcGISQtTestApp
    }
    else{
    TARGET = ArcGISQtTestApp
    }

    QMAKE_CXXFLAGS += -Wunknown-pragmas
    QMAKE_TARGET.arch = x86_64

    RUNTIME_DIR = ../../../..
    INCLUDEPATH += $${RUNTIME_DIR}/Qt/SDK/QtRuntimeCore/include
    $${RUNTIME_DIR}/Qt/SDK/ArcGISQt/include
    $${RUNTIME_DIR}/Qt/SDK/ArcGISQt
    $${RUNTIME_DIR}/include
    $${RUNTIME_DIR}/Runtime/Core/Map
    $${RUNTIME_DIR}/Runtime/Core/Map/GraphicsPipeline
    $${RUNTIME_DIR}/Runtime/Core/Map/GraphicsPipeline/LowLevelRenderer
    $${RUNTIME_DIR}/Runtime/Core/Common/Include
    $${RUNTIME_DIR}/Runtime/Core/Skia/include/core
    $${RUNTIME_DIR}/Runtime/Core/Skia/include/config
    $${RUNTIME_DIR}/Runtime/Core/libxml2/include
    $${RUNTIME_DIR}/SharedArcGIS/Include/System/Geometry/GeometryXLib
    $${RUNTIME_DIR}/SharedArcGIS/Include/GraphicsPipeline/Display/SymbolX/SymbolXLib \

    unix:DEFINES += ARCGISQT_LIBRARY
    LINUXx86
    NATIVECOMPILE
    PE_USE_CLASS_CONSTANTS
    _USE_MATH_DEFINES
    SK_SCALAR_IS_FLOAT
    SK_BUILD_FOR_UNIX
    SK_ENABLE_LIBPNG
    fdatasync=fsync
    SQLITE_THREADSAFE=1
    SQLITE_ENABLE_RTREE=1
    SQLITE_DEFAULT_FILE_FORMAT=4 \

    LIBS +=
    -L$${RUNTIME_DIR}/Qt/SDK/ArcGISQt
    -L$${RUNTIME_DIR}/bin
    -L$${RUNTIME_DIR}/Qt/SKD/QtRuntimeCore \

    LIBS += -lQtRuntimeCore
    -lArcGISQt
    -lpe
    -lpe++
    -lsg

    SOURCES += main.cpp
    MainWindow.cpp

    HEADERS += MainWindow.h
    @



  • May be I'm wrong but as long as I know, the debug_and_release works only on windows platform. On linux platform use debug or release seperate "CONFIG += debug".



  • I have modified the project file to now read

    @CONFIG += debug
    CONFIG += release@

    But the Build/Run Target Selector still will only alow me to select release as the only option.



  • Can you change the qmake build configuration on the project page (open details of build steps) ?



  • Fixed it by deleting pro.user and then specifiying debug.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.