Configuring Qt 4.8.0 for macx-icc



  • Using the following configure command:

    ./configure -prefix /Users/dllau/QtSDK/Desktop/Qt/4.8.0/icc -debug-and-release -opensource -no-qt3support -nomake demos -nomake examples -nomake tutorials -nomake -j8 -no-phonon -no-phonon-backend -platform macx-icc -continue -silent -arch x86_64 -sdk /Developer/SDKs/MacOSX10.7.sdk/

    I get the following error during make:

    linking ../../../../plugins/bearer/libqcorewlanbearer_debug.dylib
    icpc: command line warning #10159: invalid argument for option '-X'
    Undefined symbols for architecture x86_64:
    "_kCWPowerDidChangeNotification", referenced from:
    -[QNSListener init] in qcorewlanengine.o
    "_kCWAssocKey8021XProfile", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    "_kCWScanKeySSID", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    "_kCWScanKeyRestTime", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    __ZN11QScanThread3runEv in qcorewlanengine.o
    "_kCWScanKeyScanType", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    __ZN11QScanThread3runEv in qcorewlanengine.o
    "_kCWScanKeyMerge", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    __ZN11QScanThread3runEv in qcorewlanengine.o
    "_SecKeychainSearchCreateFromAttributes", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    "_SecKeychainSearchCopyNext", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    "_SecKeychainItemCopyContent", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    "_SecKeychainItemFreeContent", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    "_kCWAssocKeyPassphrase", referenced from:
    __ZN15QCoreWlanEngine11connectToIdERK7QString in qcorewlanengine.o
    "OBJC_CLASS$_CWInterface", referenced from:
    objc-class-ref in qcorewlanengine.o
    "OBJC_CLASS$_CW8021XProfile", referenced from:
    objc-class-ref in qcorewlanengine.o
    ld: symbol(s) not found for architecture x86_64

    Any one have this problem and have a fix?



  • Closed.
    This is a duplicate of "this thread":/forums/viewthread/13173/.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.