Important: Please read the Qt Code of Conduct -

Solved: QtCreator designer changes not working on Ubuntu 11.10

  • When I make changes in QtCreator Design UI for my main window, they do not appear when the app is run. They do appear
    correctly in the Designer... i.e., new actions are created and placed correctly in the object hierarchy.

    The changes DO appear in the XML of the .ui file, and the updated file is saved. But they DO NOT get reflected in the
    ui_windowname.h file. The project builds as if all is well, but if I remove that ui_windowname.h file, I get the error message:

    no rule to make target "ui_windowname.h", needed by 'window name.o'. Stop

    Particulars are: QtCreator 2.3.1, Qt 4.7.4 with all updates as per SDK manager, Ubuntu 11.10 with all updates installed.

    Any suggestions for why the updated XML isn't being processed into the app?


    Update: Solved by creating a new project and repopulating it with h, cpp, ui and resource files. Problem was due to stuff in folder left from building the project with Qt 4.8 on Mac OS

  • I was have same problem)

  • Moderators

    Try touching *.ui files and then cleaning the project.

    Make (which is used to decide which parts of the code need to be rebuild) is based on timestamps on the files. If you had your system clock screwed up once that can cause some interesting issues with stuff not getting rebuild properly:-)

Log in to reply