Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Error: 'Failed to extract plugin meta data'



  • Hello everyone. I am trying to build a Qt application with PySide2 to be used on a Raspberry Pi. I'm programming on a Linux machine, with no problems. When I try to run the code on the Raspberry, I get the following error:

    main.qml:1 plugin cannot be loaded for module "QtQuick": Failed to extract plugin meta data from '/opt/Qt/5.15.2/qml/QtQuick.2/libqtquick2plugin.so'
    

    On main.py, I set the QML import path as:

    engine = QQmlApplicationEngine()
    engine.addImportPath("/opt/Qt/5.15.2/qml/")
    
    

    The import line on main.qml that results in the error is:

    import QtQuick 2.15
    

    The Raspberry Pi has Qt 5.15.2 installed. I've tried searching for this error online, and I've came accross some posts mentioning Python 3.8 might be an issue on windows, however I am running Python 3.7.3. Do you know how could I fix this issue?

    Thanks for your time!



  • @raphasauer I have the same issue. Could you solve it?