Important: Please read the Qt Code of Conduct -

[Solved] Qt 4.8.0 fonts not matching 4.7.4 compiles

  • I would be grateful if someone could steer me out of my problem. All applications I compile on QTSDK Creator using 4.7.4 compile with normal fonts but when I use 4.8.0 library the fonts are incorrect with sizes being larger and dots in the Zeros. They are very clunky looking.

    When I run assistant from a terminal the same clunky fonts are there and I get error messages as follows which may be a clue ...
    $ assistant
    Could not load translation file assistant_en_NZ in directory /usr/local/Trolltech/Qt-4.8.0/translations.
    Could not load translation file qt_en_NZ in directory /usr/local/Trolltech/Qt-4.8.0/translations.
    Could not load translation file qt_help_en_NZ in directory /usr/local/Trolltech/Qt-4.8.0/translations.
    Object::connect: No such signal HelpViewer::printRequested()

    If necessary I can supply screen shots of the 4.8.0 vs 4.7.4 compiles and would add that they are correct on other users machines. It seems mine is the only one giving trouble. My OS is Linux Mint 11 and all Mint and Qt updates have been installed.

  • Here are a couple of screenshots of my application showing the difference between compiling with Qt4.7 and Qt4.8

    Here is my Qt4.8 output


    Here is how it should look


    I would be grateful for any suggestions as to why these fonts are not right.

  • I got same problem on Ubuntu 11.10. Qt4.7.4 compiles are fine, but compiling same project with 4.8.0 results in messed up fonts. I've been even trying to load custom font with QFontDatabase::addApplicationFont, but had no success...

  • I simply re installed Qt 4.8.0 library and it all came right. Thanks to those who looked at the message. Sorry I am not sure of how to mark the message as solved properly so this is the best I can do.

Log in to reply