Qt6 topics merged with General

Qt5 xcb plugin compilation

  • Hi,
    I compiled Qt5 version (5.12.10) from git repository with various modules (including systems and x11) on Kubuntu 14.
    I used this version as SDK for my application and it compiled successfully.
    My application pack all needed libs as a package and is not using libs installed on system.
    When I tried to run the application, I got error message that I am missing xcb plugin.
    And it was missing as a plugin and as libqxcb.so in my compiled Qt5 libs.
    I tried to find information on how to compile this plugin / .so , but I couldn't find anything.
    Any help will be appreciated.

  • Lifetime Qt Champion

    During configure stage the summary output shows you if the xcb plugin gets compiled or not. In config.log you can see why it may not be compiled.

  • Thanks for answer.
    In the log I didn't found the reason why it didn't compiled.
    But during configure I can see that I am missing some system libs for qpa-xcb. I am not sure that qpa-xcb = libqxcb.so, but I will try to resolve my missing system libs and update if it helped.

  • Apparently my system libs didn't matched requirements,
    I think I can't build this version on Kubuntu 14 without "stitching" these system libs,
    So I ended up building lesser (5.9) version.

  • Lifetime Qt Champion

    @Alex_Kr said in Qt5 xcb plugin compilation:

    Kubuntu 14

    This is a 7 years old distribution without any support (not even security patches)!
    I would say it's time to upgrade :-)

Log in to reply