Important: Please read the Qt Code of Conduct -

Can't use Android with Qt 5.15 because SDK Manager not works

  • Hi,
    I just installed Qt 5.15.2 for Win10 and Android.

    First I let Qt install the SDK Manager. After this I'm getting a message that many packages are missing. "Do you want to install the missing packages?" YES. Press Ok and then nothing is installed only the proceed bar increases to 100%.

    Then I used this manual and installed from the console.

    This worked but now still to packages are missing, the SDK Manager does still not work as before.

    Android SDK Platfrom 30
    Android SDK Build Tools 30.0.2

    I tried also directly with SDK Manager but thats the same.

    What I'm doing wrong here and does someone know the command line commands to update these two packages?

    Is it a problem to have installed in parallel Qt 5.12.2? I use JDK 1.8.0_101.


  • Now I completely deleted all Qt Versions and installed again At 5.15.2. But unfortunately no change. The SDK Manager does not work. After Installing the missing packages the proceed bar goes to 100% and then everything is grey out and disabled.


    I used the default installation for 5.15.2 . What can be the reason for that?

  • That's crazy, today after this message window was open for 10 minutes a new message window opened and told me something about that my Android SDK license is not correct. After pressing a few times of YES everthing is ok now.

Log in to reply