Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Another "now what ?"



  • I have decided to "downgrade" from 6.0.2 back to QtCreator with operational / working Bluetooth module.

    The download of 5.15 went OK.

    Without selecting a project I ended up with displaying previously working 6.0.2. project.

    Went back to "edit" mode and made numerous fruitless attempts to build / run etc. the only currently active project ( previously working in 6.0.2 ).
    NONE OF THE STANDARD BUILD OPTIONS ARE AVAILABLE TO SELECT / EXECUTE /RUN , ALL GRAYED OUT !

    What does Options ->Kits->Kits "replacement for "desktop Qt 6.0.1 ...." telling me ?

    BTW my last working project was Qt 6.0.2 , not 6.0.1.

    9f0aa0ab-8641-41a7-9e7f-d3924b5cbfa7-image.png

    Any suggestion in getting my new QtCreator to ENABLE to build my formerly working project.

    PS
    I really does not matter , to me , to know why Qt numbering scheme is what it is . I need working QtCreator.


  • Moderators

    @AnneRanch said in Another "now what ?":

    NONE OF THE STANDARD BUILD OPTIONS ARE AVAILABLE TO SELECT / EXECUTE /RUN , ALL GRAYED OUT !

    Tell us which kit(s) you have enabled for this project. Screenshot at https://doc.qt.io/qtcreator/creator-configuring-projects.html



  • @JKSH Did not I posted that in original post ?
    I do not get what else you are asking for.

    I do not have windows likes yu are referring too.

    Is Windoze and Linux really that much different to download and use ?

    Is this part of the issue ?
    Repost

    What does Options ->Kits->Kits "replacement for "desktop Qt 6.0.1 ...." telling me ?

    I have deleted "Kits "replacement for "desktop Qt 6.0.1 ...." AND NOW i CAN BUILD THE PROJECT.


  • Moderators

    @AnneRanch said in Another "now what ?":

    Did not I posted that in original post ?

    No, you did not.

    You showed us which kits are available on your PC. You showed us that you had Qt 6.0.1 and Qt 5.15.2 installed

    However, you did not show us which kit(s) were selected for your project. Different projects can choose different kits. For example, one project can select Qt 6.0.1, while another project can select Qt 5.15.2.


Log in to reply