Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Updated XCode and everything is broken



  • I recently updated XCode to Version 12.4 and Qt Creator to version 4.14.1 with Qt 5.15.2 and Clang 11.0. Now when I try to build my project, I get the following warnings:

    Project WARNING: Qt has only been tested with version 10.15 of the platform SDK, you're using 11.1.
    Project WARNING: This is an unsupported configuration. You may experience build issues, and by using
    Project WARNING: the 11.1 SDK you are opting into new features that QT has not been prepared for.
    Project WARNING: Please downgrade the SDK you use to build your app to version 10.15, or configure
    Project WARNING: with CONFIG+=sdk_no_version_check when running qmake to silence this warnining.
    

    Prior to updating XCode, everything worked fine. I also cloned this simple project from github and I get the same result https://github.com/retifrav/color-corners

    When I open XCode and try to compile, I see the splash screen and then get a crash with a completely different error. Something about a bad nib file.

    I suppose the solution may be to downgrade the SDK to 10.15 like the warning says. But I have no idea how to do that.


  • Lifetime Qt Champion

    @kgregory These are warnings, not errors. It should still compile. So, does it compile? Also, you could try what is suggested: CONFIG+=sdk_no_version_check



  • Yes I can ignore the warning but I can't get it to run on the iPad either from QT or Xcode. I downgraded xcode to 11.7 and that seems to have a different issue, which it seems lots of people are having, described here: https://developer.apple.com/forums/thread/130223?page=2.

    When I had the latest version of xcode (12.x) it would start to run and then crash as soon as I saw a splash screen, saying something about an invalid nib bundle (I don't know what that is). I recall seeing something new related to splash screens in the release notes. Do I need to implement the splash screen differently.

    I'll upgrade back to 12.x tomorrow night and then I can give you more specific error messages.


  • Moderators

    @kgregory I'm running Xcode 12.4, Creator 4.14 and so far that Xcode version is one with the least problems I had.

    To be fair, I do build my (Qt)iOS version myself and do not use the precompiled libs.
    But I do have run and distributed Apps with this combination of Xcode and Qt



  • OK so when I upgrade back to the latest version of XCode (12.4), I run QMake and then open xcode and run from there. My launch screen comes up and then it freezes and I get an error message that says:

    Could not load NIB in bundle: 'NSBundle </private/var/containers/Bundle/Application/<..some code..>/BlueGhoztApp.app> (loaded)' with name 'LaunchScreen'' terminating with uncaught exception of type NSException

    Can anyone point me at a working example iOS app that I can use as a test case to make sure it's not an issue with my app?



  • @kgregory for the benefit of anyone anyone who is reading this, I went back to Qt 5.12.10 and this "Could not load NIB in bundle" issue went away.

    I don't have a compelling reason to use 5.15, so I'll just stick with 5.12 for now, but it would be nice to figure out what's going on here.


Log in to reply