QTextEdit and Symbian



  • Hi,

    I'm building a QT application for Symbian, and one major problem i'm having is with QTextEdit, when i run it on my development device (a Nokia 5800 with Portuguese language) it doesn't seem to accept input (none of the keys causes any output) from the full qwerty virtual keyboard or the mini qwerty keyboard, the only input accepted is from the T9 virtual keyboard.

    I kept all the default widget attributes, but i found there is a "inputMethodHints" attribute, do i need to change this attribute for the qwerty keyboard to work?

    Also strange is that QLineEdit seems to work with the referred input methods, but in this case the backspace key doesn't delete the previous character.
    P.S. I'm running on QT 4.7 but the same problem occurs with 4.6.

    Is there something i'm doing wrong?

    Thank you for your time.



  • For the record this problem doesn't occur in QT 4.6.3 as i said earlier. It only happens in QT 4.7.

    This kind of solves my problem since the current recomended QT version for symbian is indeed 4.6.3, and the only version supported by "nokia smart installer".



  • If you can provide a minimal test case program which exhibits the faulty behaviour, please do make a bug report on bugreports.qt.nokia.com and fully describe the environment (device, version of Qt, etc), what you expect to see, and what you did see - and attach your minimal test case program.

    If this is a bug in Qt 4.7 we'd certainly like to be able to test it, fix it, and add a test case so that it doesn't regress in the future; but without a bug report we cannot track the issue.

    Thanks,
    Chris.



  • I'll do that.

    Thanks,
    Hugo.



  • Hello, I met the problem before. Now I solved the problem.

    I just changed the qt_installer version on the phone. And the problem disappeared.

    Now the version of the qt_installer is 4.7.1 from the SDK I downloaded.

    You can try a new qt_installer.

    Good luck.
    Hisong.



  • hey hisong1988, thank you for the follow up. ;)

    hlima, did you report it in the "Qt bug tracker":http://bugreports.qt.nokia.com ? If so, remember the number?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.