Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Howto get rid of qmake old DESTDIR setting?



  • I'm building a win32 application using qtcreate and qmake. I'm using a toplevel project to build subprojects. In one of the included .pri files I use to have DESTDIR set to libs_non_debug. I have changed this .pri file but the makefiles generated still use this DESTDIR. I have searched my entire system (including) registry for the text libs_non_debug but cannot find it. How do I get rid of this?



  • @ThisIsEusch

    HI and welcome to devnet forum

    Did "Run qmake" under "build" or otherwise?
    That should cure your problem.



  • I did run "run qmake" several times. What I don't understand where does the value libs_non_debug keep coming from. This is the old directory I cannot get rid off.



  • @ThisIsEusch

    Do you use a file ".qmake.conf" or ".qmake.cache" in the project folder or above?
    Check them for this entry. ".qmake.conf" is often used for general settings as tobe used in different projects beyond the file location. qmake is actively searching for the file.


Log in to reply