Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Windows 7 to Windows 10 ?



  • I am testing my software on various OS's using Oracle VirtualBox to install virtual machines. I have a Windows 7 CD which is licensed and was purchased when it was current. I then updated to Windows 10 when it became available, that was a few years ago, I don't remember having to pay for the upgrade.

    I've installed Windows 7 in a virtual machine and I would like to update it to Windows 10, but it doesn't look like its a free upgrade anymore, can anyone confirm or help?


  • Moderators



  • @J-Hilk , thank you.



  • @SPlatten I remember you mentioned somewhere else that your host system is macOS? If that's the case Vbox with Windows 10 guest os can be seriously broken. I tried that two years ago - editing the text in QtCreator was next thing to impossible, every key has been entered at least twice and it was laggy. Very laggy. It may be that they fixed it in VBox, as well they might not.
    I ended up using Parallels Desktop as VM solution for Windows.
    Debian worked sufficiently well though.



  • @artwaw I really just want to use the virtual machine so I can test my software on different operating systems, I didn't plan to do any development on these.

    I haven't used Parallels before.



  • @SPlatten Parallels is a great solution for macOS, I use it extensively for over two years now. Previously I worked on Debian and used VBox for Windows. When I switched to macOS (I needed to include macOS in my works) and VBox became a no-go. But - Parallels is paid solution but offers much, much more than Vbox ever did.
    It might be that for your needs VBox will suffice, I never tested it once I discovered that I can't run QtCreator properly.



  • @artwaw , thank you, I might just buy it on my company....Windows is such a load of crap, just trying to get to Windows 10 update assistant page and Windows Explorer (Not Responding), all to familiar...This is one of the reasons I move to Apple, this kind of thing just doesn't happen.

    I've just installed Chrome and gone to the link and now the update is in progress.


Log in to reply