Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtCreator shows error where there's none



  • Hello everyone !

    I've a strange problem and I do not find answers by myself.
    I code with QtCreator on a LinuxMint laptop and, with each i work on, QtCreator shows me error where there is none.
    a116ff3f-ed12-4a19-a289-98035194a3c2-image.png

    Look at this picture above. This is a whole new project for the example. I can build and execute the project properly but still, this is really annoying to have this kind of display while programming. I've opened the same project on a raspi just to see if I had the same display of error, but I had no error on the raspi.

    Does anybody has an idea why QtCreator is doing that on my laptop ?

    When i look "qtcreator -version" in the terminal it returns me "Qt Creator 4.11.0 based on Qt 5.12.8" and my distribution is "Linux Mint 20 Ulyana"

    Thanks for the help,
    Have a nice day



  • @Jaykobb
    In move to Ubuntu 20.04 I had to apt get the Clang 9 version (I think sudo apt install clang-9?) to get rid of spurious Creator marks like this, assuming you're using the default parser of clang in your settings. Might need the same for Mint?



  • Hello !
    Thank you for your help :)
    I tried it and several others but nothing really worked. I ended up to purge every packages related to qt and made a whole new installation of QtCreator, so I don't really know where the problem came from.

    (Sorry for the laaaaate respond, I had no time to look up after that this month ^^')


Log in to reply