Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Configure qt with -opengl for jetson tx2 fails.



  • ./configure -shared -c++std c++14 -opensource -release --confirm-license -no-pkg-config -device linux-jetson-tx1-g++ -device-option CROSS_COMPILE=/home/sreeja/tools/gcc-linaro-6.5.0-2018.12-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- -sysroot /home/sreeja/nvidia/TX2_rootfs/ -nomake examples -nomake tests -prefix /usr/local/qt5 -extprefix /home/sreeja/QT5.9.9/JetsonTX2/qt5 -hostprefix /home/sreeja/QT5.9.9/JetsonTX2/qt5-host -skip webview -skip qtwebengine \ --opengl es2

    • cd qtbase
    • /home/sreeja/tools/QT/qt-everywhere-src-5.15.0/qtbase/configure -top-level -shared -c++std c++14 -opensource -release --confirm-license -no-pkg-config -device linux-jetson-tx1-g++ -device-option CROSS_COMPILE=/home/sreeja/tools/gcc-linaro-6.5.0-2018.12-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- -sysroot /home/sreeja/nvidia/TX2_rootfs/ -nomake examples -nomake tests -prefix /usr/local/qt5 -extprefix /home/sreeja/QT5.9.9/JetsonTX2/qt5 -hostprefix /home/sreeja/QT5.9.9/JetsonTX2/qt5-host -skip webview -skip qtwebengine --opengl es2
      Creating qmake...
      .Done.
      ERROR: Invalid command line parameter ' --opengl'.
      Please help me to solve this issue.I have EGL,GLES2,GLES3 folders in sysroot/usr/include.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    As the error says there's no --opengl option. If you take a look at the configure --help output you'll see that it is -opengl.



  • Your reply surely helped.Thanks.
    When I added -opengl at the end,it didnt work.
    Worked when i did like this:
    ./configure -shared -c++std c++14 -opensource -release --confirm-license -no-pkg-config -device linux-jetson-tx1-g++ -device-option CROSS_COMPILE=/home/sreeja/tools/gcc-linaro-6.5.0-2018.12-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- -sysroot /home/sreeja/nvidia/TX2_rootfs/ -nomake examples -nomake tests -prefix /usr/local/qt5 -extprefix /home/sreeja/QT5.9.9/JetsonTX2/qt5 -hostprefix /home/sreeja/QT5.9.9/JetsonTX2/qt5-host -opengl es2 -skip webview -skip qtwebengine


  • Lifetime Qt Champion

    If you have it working now please mark the thread as solved so that other forum users may know a solution as been found :-)


Log in to reply