Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Building Error While Building Cross Compile for Raspberry pi 4



  • Hello.

    I struggle for cross compiling for Raspberry pi 4. My OS is Ubuntu 20.04. I builded cross compile platform and I have been run simple quick application. (I created project on PC and I could see output window on Raspberry pi screen).

    I want run more big project on Raspberry pi4 with cross compile. I want edit code on my PC and I want see output on Raspberry pi 4. I have been worked this project on Raspberry pi 4 without qt.

    I tried run qmake for .pro file and I compiled the resulting makefile file. It's working. I want do same process with cross compile but I have errors this place. Qt does not find some .so files but I checked and this files are exist on the specified path.

    P.S. I used this commands when I building cross compile. https://github.com/PhysicsX/QTonRaspberryPi/blob/main/qt5.14.2onRaspberrypi

    My .pro file this:

    QT += quick widgets serialport multimedia
    CONFIG += c++11
    
    # The following define makes your compiler emit warnings if you use
    # any Qt feature that has been marked deprecated (the exact warnings
    # depend on your compiler). Refer to the documentation for the
    # deprecated API to know how to port your code away from it.
    DEFINES += QT_DEPRECATED_WARNINGS
    
    
    INCLUDEPATH += -I/opt/qt5pi/sysroot/usr/include/opencv2
    LIBS += -L/opt/qt5pi/sysroot/usr/lib -lopencv_core -lopencv_highgui -lopencv_imgcodecs -lopencv_imgproc -lopencv_videostab  -lopencv_features2d
    
    # You can also make your code fail to compile if it uses deprecated APIs.
    # In order to do so, uncomment the following line.
    # You can also select to disable deprecated APIs only up to a certain version of Qt.
    #DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x060000    # disables all the APIs deprecated before Qt 6.0.0
    
    SOURCES += \
            main.cpp \
        file.cpp \
        gcodesender.cpp \
        movementmanager.cpp \
        usbmanager.cpp \
        imageresizer.cpp \
        serialcommunicator.cpp \
        frameprocessor.cpp
    
    RESOURCES += qml.qrc
    
    
    # Additional import path used to resolve QML modules in Qt Creator's code model
    QML_IMPORT_PATH =
    
    # Additional import path used to resolve QML modules just for Qt Quick Designer
    QML_DESIGNER_IMPORT_PATH =
    
    # Default rules for deployment.
    qnx: target.path = /tmp/$${TARGET}/bin
    else: unix:!android: target.path = /home/pi/dev/$${TARGET}/
    !isEmpty(target.path): INSTALLS += target
    
    HEADERS += \
        file.h \
        gcodesender.h \
        movementmanager.h \
        usbmanager.h \
        imageresizer.h \
        serialcommunicator.h \
        frameprocessor.h
    
    DISTFILES += \
        theme/DarkTheme_copy.qml \
        theme/WhiteTheme.qml
    
    

    And my compiled output(Just errors): https://pastebin.pl/view/cbeede8a

    How can I fix error ?

    Thanks


Log in to reply