Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtCreator fails on MacOS SDK 11.1



  • I have Qt5 from brew in: /usr/local/Cellar/qt5/5.15.2/bin/

    I use QtCreator 4.12.82.

    I have MacOS Big Sur 11.1 with XCode installed in ls /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX11.1.sdk

    When I create a new standard project in QtCreator I get the following error:

    10:35:16: Running steps for project test2...
    10:35:16: Starting: "/usr/local/Cellar/qt/5.15.2/bin/qmake" /Users/joefresna/VideoImageEdit/test2/test2.pro -spec macx-g++ CONFIG+=x86_64 CONFIG+=qtquickcompiler
    Project WARNING: Qt has only been tested with version 10.15 of the platform SDK, you're using 11.0.
    Project WARNING: This is an unsupported configuration. You may experience build issues, and by using
    Project WARNING: the 11.0 SDK you are opting in to new features that Qt has not been prepared for.
    Project WARNING: Please downgrade the SDK you use to build your app to version 10.15, or configure
    Project WARNING: with CONFIG+=sdk_no_version_check when running qmake to silence this warning.
    10:35:17: The process "/usr/local/Cellar/qt/5.15.2/bin/qmake" exited normally.
    10:35:17: Starting: "/usr/bin/make" -f /Users/joefresna/VideoImageEdit/build-test2/Makefile qmake_all
    /usr/local/Cellar/qt/5.15.2/mkspecs/features/mac/sdk.mk:22: *** ^.  Stop.
    The platform SDK has been changed from version 11.0 to version 11.1.
    This requires a fresh build. Please wipe the build directory completely,
    including any .qmake.stash and .qmake.cache files generated by qmake.
    10:35:20: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project test2 (kit: Qt 5.15)
    When executing step "qmake"
    10:35:20: Elapsed time: 00:04.
    

    (Note that even if I delete the build directory I still get the warning about wiping the directory)

    The QtCreator Kit points to the qt installed via brew (indicated above). I tried to change the compilers in QtCreator > Projects > Manage Kits > Kits > Compiler and I tried both GCC and Clang from /usr/bin and from XCode, without success.

    When I type xcodebuild -showsdks, I get:

    iOS SDKs:
        iOS 14.4                        -sdk iphoneos14.4
    
    iOS Simulator SDKs:
        Simulator - iOS 14.4            -sdk iphonesimulator14.4
    
    macOS SDKs:
        DriverKit 20.2                  -sdk driverkit.macosx20.2
        macOS 11.1                      -sdk macosx11.1
    
    tvOS SDKs:
        tvOS 14.3                       -sdk appletvos14.3
    
    tvOS Simulator SDKs:
        Simulator - tvOS 14.3           -sdk appletvsimulator14.3
    
    watchOS SDKs:
        watchOS 7.2                     -sdk watchos7.2
    
    watchOS Simulator SDKs:
        Simulator - watchOS 7.2         -sdk watchsimulator7.2
    

    Do you know how to solve this problem?


  • Moderators

    @joefresna
    check (generally) for a hidden .qmake.stash file, it does not necessarily live inside your build folder, and delete that



  • @J-Hilk said in QtCreator fails on MacOS SDK 11.1:

    .qmake.stash

    Thank you so much! This was the solution!! There was a .qmake.stash outside the build folder. Deleting it has solved my issue! Thank you!Thank you!Thank you!Thank you!Thank you!


  • Lifetime Qt Champion

    @joefresna Just a hint: that was exactly what was mentioned in the output: "Please wipe the build directory completely,
    including any .qmake.stash and .qmake.cache files generated by qmake."


Log in to reply