Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Building 4.8 from source on Mac OS X 10.6 + Xcode 4.2



  • I downloaded the new source package from http://download.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.8.0.zip and tried to build it myself.

    First I ran into this error: [code]-bash: ./configure: /bin/sh^M: bad interpreter: No such file or directory[/code]
    It turns our configure script is saved with Windows CR/LF line feeds. So I changed it to Unix LFs. Then I get this: [code]You don't seem to have 'make' or 'gmake' in your PATH.[/code]
    But I do!
    [code]stephenchu$ which make
    /usr/bin/make[/code]

    WTF is going on? I used to be able to build 4.7 from source without any issues. Is this the new direction Qt for desktop going?



  • There once was a note on the download page that the zip contains windows style line endings, whereas the .tar.gz has unix style. I would suggest to try with the tar.gz. With that the configure script starts on my box.

    The build fails, due to missing .pri files, though. It would be interesting, if it works for you.



  • The build with default settings works, the error about missing .pri files is only during the configure phase and can be ignored.


Log in to reply